Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 37757 - Ability to add and edit watch expressions in-place
Ability to add and edit watch expressions in-place
Status: CLOSED FIXED
Product: debugger
Classification: Unclassified
Component: Code
3.x
All All
: P2 (vote)
: 6.x
Assigned To: Martin Entlicher
issues@debugger
: UI, USABILITY
: 101926 101928 (view as bug list)
Depends on: 104281 108861 136658
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-04 19:55 UTC by _ gtzabari
Modified: 2010-04-29 09:15 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ gtzabari 2003-12-04 19:55:29 UTC
When adding a new WATCH I should just be able
to shift focus to the WATCH window, click one
"slot" past the last one and begin typing and
it'll add a new WATCH.

   When I want to change the watch expression, I
should be able to click on it and edit it in-place
instead of having to go into the properties menu.
Comment 1 Roman Ondruska 2005-05-13 10:36:10 UTC
Ok, current approach could be slow when user is to add lot of watches.
Comment 2 Martin Entlicher 2007-05-17 16:56:43 UTC
Increasing priority, we have more reports in this area.
Comment 3 Martin Entlicher 2007-05-17 16:57:38 UTC
*** Issue 101926 has been marked as a duplicate of this issue. ***
Comment 4 Martin Entlicher 2007-05-17 16:58:27 UTC
*** Issue 101928 has been marked as a duplicate of this issue. ***
Comment 5 Martin Entlicher 2007-05-18 15:08:08 UTC
Adjusting the summary, we'll try to make it into M10.
Comment 6 _ gtzabari 2007-05-18 15:24:57 UTC
I am a bit confused by the new summary. Just to make sure we're on the same
page, my understanding is that this feature consists of two separate use-cases:

1) The ability to drag-n-drop selected text from the editor into the watch window
2) The ability to click on an "empty slot" and type a new watch "inline"

Can you please clarify whether you plan on handling use-case #1 as well?
Comment 7 _ gtzabari 2007-05-18 15:26:11 UTC
My mistake, use-case one is covered by a separate issue #44575.
Comment 8 Martin Entlicher 2007-05-18 16:14:05 UTC
Right. I consider this one to be about in-place editing and adding a new Watch
by clicking one "slot" past the last one. Issue #44575 is about drag-and-drop.
Comment 9 Martin Entlicher 2007-06-06 22:56:05 UTC
It's implemented in trunk:

/cvs/debuggerjpda/src/org/netbeans/modules/debugger/jpda/models/WatchesModel.java,v
 <--  WatchesModel.java
new revision: 1.36; previous revision: 1.35

/cvs/debuggerjpda/ui/src/org/netbeans/modules/debugger/jpda/ui/models/VariablesNodeModel.java,v
 <--  VariablesNodeModel.java
new revision: 1.19; previous revision: 1.18

/cvs/debuggerjpda/ui/src/org/netbeans/modules/debugger/jpda/ui/models/VariablesTableModel.java,v
 <--  VariablesTableModel.java
new revision: 1.20; previous revision: 1.19

/cvs/debuggerjpda/ui/src/org/netbeans/modules/debugger/jpda/ui/models/WatchesActionsProvider.java,v
 <--  WatchesActionsProvider.java
new revision: 1.11; previous revision: 1.10

/cvs/debuggerjpda/ui/src/org/netbeans/modules/debugger/jpda/ui/models/WatchesNodeModel.java,v
 <--  WatchesNodeModel.java
new revision: 1.16; previous revision: 1.15
Comment 10 _ gtzabari 2007-07-02 17:47:57 UTC
I don't really agree that this issue is completed fixed. I was expecting to be able to add watches directly in the watch
window. Double clicking on the empty slot pops up the "Add Watch" wizard which is a good start but can't we do away with
this wizard altogether and allow the user to type in the expression directly in the watch window? Should I open a new
issue to that effect?
Comment 11 Martin Entlicher 2007-07-04 13:04:34 UTC
I've submitted issue #108861 for that. It's possible to get the row into the editing mode after several single-clicks,
but this is because of some strange bug. One click should be enough. Please provide eny comments you have to the editing
functionality into issue #108861. Thanks.
Comment 12 Martin Entlicher 2007-09-20 17:51:36 UTC
Reopening, we're removing this functionality due to implementation problems. (issue #108861)

/shared/data/ccvs/repository/debuggerjpda/src/org/netbeans/modules/debugger/jpda/models/WatchesModel.java,v  <-- 
WatchesModel.java
new revision: 1.41; previous revision: 1.40

/shared/data/ccvs/repository/debuggerjpda/ui/src/org/netbeans/modules/debugger/jpda/ui/models/WatchesNodeModel.java,v 
<--  WatchesNodeModel.java
new revision: 1.19; previous revision: 1.18
Comment 13 Martin Entlicher 2010-01-25 06:22:15 UTC
Implemented again in NB 6.8. It's based on Outline and should work more reliably.
Comment 14 Quality Engineering 2010-04-29 09:15:37 UTC
Verified ... and Closing all issues resolved into NetBeans 6.7 and earlier.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo