Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 153004 - Local Variables does not show full list of variables
Local Variables does not show full list of variables
Status: CLOSED FIXED
Product: debugger
Classification: Unclassified
Component: Code
6.x
PC Linux
: P3 (vote)
: 6.x
Assigned To: Martin Entlicher
issues@debugger
:
Depends on: 136658
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-12 03:02 UTC by pbw
Modified: 2010-04-29 09:45 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Gzipped tar file containing NB project. (1.11 MB, application/x-gzip)
2008-11-12 03:03 UTC, pbw
Details
Gzipped tar file containing PNG images. (638.54 KB, application/x-gzip)
2008-11-12 03:05 UTC, pbw
Details
tar.gz containing library jars needed to compile project. (2.20 MB, application/x-gzip)
2008-11-12 07:36 UTC, pbw
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pbw 2008-11-12 03:02:07 UTC
NB daily 200811071401 JDK 1.6.0_10. When debugging the code included as an attachment, I find inconsistent display of
local variables.

Get the project from the attached project tar.gz. Get the attached tar.gz file containing jpegs. Extract the jpegs,
named breakpoints.png and breakpoints1.png to breakpoints4.png.

breakpoints.png shows the breakpoints.

Start debugging the file au.id.pbw.linefold.tests.ParagraphDisplay.java

Continue from each point until lien 663 in Paragraph.java. breakpoints1.png shows my Local Variables display. Note that
there is no entry for "this".

Step into methods until line 678 of ParagraphData.java, method get_visual_advance_to. breakpoints2.png shows my display.
Again, no "this".

Step through to line 654, method get_advance_to. breakpoints3.png shows an entry for "this".

Step across methods until line 661 of Paragraph.java. breakpoints4.png shows that "this" is now available for
Paragraph.java.
Comment 1 pbw 2008-11-12 03:03:50 UTC
Created attachment 73652 [details]
Gzipped tar file containing NB project.
Comment 2 pbw 2008-11-12 03:05:31 UTC
Created attachment 73654 [details]
Gzipped tar file containing PNG images.
Comment 3 pbw 2008-11-12 07:34:04 UTC
You'll need another set of jars. See attachment.
Comment 4 pbw 2008-11-12 07:36:51 UTC
Created attachment 73659 [details]
tar.gz containing library jars needed to compile project.
Comment 5 Martin Entlicher 2008-11-18 15:31:56 UTC
It took me some time to run the attached program, missing fonts breaks the execution, but the exception is not reported.

I've submitted breakpoints according to the screenshots, and after some time managed to reproduce this issue.
It looks like "break_mode" is displayed instead of "this" when the table is sorted according to "Name".
Comment 6 Martin Entlicher 2008-11-18 15:39:17 UTC
Thanks for the projects that can be used to reproduce this, we'll check if this is fixed after issue #136658 is fixed.
Comment 7 Martin Entlicher 2009-04-20 17:17:44 UTC
I've followed the same steps in build 090415 and I see "this" node in Variables window everywhere. Therefore this got
fixed after issue #136658 was fixed.
Comment 8 Quality Engineering 2010-04-29 09:45:26 UTC
Verified ... and Closing all issues resolved into NetBeans 6.7 and earlier.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo