Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 105082 - MouseUtils holds reference to node even after editor is closed
MouseUtils holds reference to node even after editor is closed
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Window System
6.x
All All
: P2 (vote)
: 6.x
Assigned To: David Simonek
issues@platform
: PERFORMANCE
: 100755 (view as bug list)
Depends on:
Blocks: 105078 105079
  Show dependency treegraph
 
Reported: 2007-05-29 23:51 UTC by Shivanand Kini
Modified: 2008-12-22 13:46 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Object path from mouse utils to wsdl editor node (23.12 KB, application/octet-stream)
2007-05-29 23:52 UTC, Shivanand Kini
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Shivanand Kini 2007-05-29 23:51:07 UTC
Attached is the profiler object path.


Install enterprise pack.
Create a new bpel module
Create a new WSDL file.
select a node in the tree view.
Close the editor.

Do a memory profile here. 

You will see that the mouseutils still has a reference to the node, which doesnt
allow the node to be garbage collected.
Comment 1 Shivanand Kini 2007-05-29 23:52:41 UTC
Created attachment 42926 [details]
Object path from mouse utils to wsdl editor node
Comment 2 Petr Nejedly 2007-05-30 13:23:34 UTC
*** Issue 100755 has been marked as a duplicate of this issue. ***
Comment 3 David Simonek 2007-05-30 14:57:21 UTC
fixed in main trunk, simply use WeakReference.

Checking in MouseUtils.java;
/cvs/openide/awt/src/org/openide/awt/MouseUtils.java,v  <--  MouseUtils.java
new revision: 1.3; previous revision: 1.2
Comment 4 Quy Nguyen 2007-06-12 23:15:24 UTC
Verified on 070612.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo