Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 100755 - Last editor held by MouseUtils.tempe
Last editor held by MouseUtils.tempe
Status: RESOLVED DUPLICATE of bug 105082
Product: platform
Classification: Unclassified
Component: Window System
6.x
All All
: P3 (vote)
: TBD
Assigned To: Petr Nejedly
issues@platform
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-12 10:36 UTC by _ rkubacki
Modified: 2008-12-22 11:39 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ rkubacki 2007-04-12 10:36:39 UTC
This has ability to hold tens of megabytes for editors like XML.

Static reference from org.openide.awt.MouseUtils.tempe (from class
org.openide.awt.MouseUtils) :
--> java.awt.event.MouseEvent@0x75592228 (61 bytes) (field source:)
--> org.netbeans.modules.xml.xam.ui.column.ColumnListView$ColumnList@0x74c53238
(381 bytes) (field this$0:)
--> org.netbeans.modules.xml.xam.ui.column.ColumnListView@0x74c63538 (430 bytes)
(field parent:)
--> org.netbeans.modules.xml.schema.ui.basic.SchemaColumn@0x74c7e400 (340 bytes)
(field columnView:)
--> org.netbeans.modules.xml.schema.ui.basic.SchemaColumnsView@0x74cb0348 (352
bytes) (field parent:)
--> javax.swing.JPanel@0x74cd0bb8 (320 bytes) (field parent:)
--> org.netbeans.modules.xml.xam.ui.category.DefaultCategoryPane$1@0x74cd09e8
(324 bytes) (field parent:)
-->
org.netbeans.modules.xml.schema.core.multiview.SchemaColumnViewMultiViewElement@0x74c63208
(386 bytes) (field parent:)
--> javax.swing.JPanel@0x749e7338 (320 bytes) (field component:)
--> [Ljava.awt.Component;@0x74c63bc8 (20 bytes) (Element 0 of
[Ljava.awt.Component;@0x74c63bc8:)
-->
org.netbeans.modules.xml.schema.core.multiview.SchemaSourceMultiViewElement@0x74734e00
(415 bytes)
Comment 1 _ rkubacki 2007-04-12 12:19:04 UTC
It seems enough to hold just weak reference to event
Comment 2 Quy Nguyen 2007-05-29 23:41:20 UTC
The MouseUtils class is used directly by the visualweb editor and causes a
fairly significant memory leak issue.  Since the visualweb data structures are
hierarchical (e.g. a page fragment is embedded in another page), multiple editor
TopComponents leak from the MouseUtils.tempe field.
Comment 3 Petr Nejedly 2007-05-30 13:23:38 UTC
Dafe will take care of this.
Thanks, Dafe.

*** This issue has been marked as a duplicate of 105082 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo