Bug 197114

Summary: [70cat] StackOverflowError at java.util.regex.Pattern$BmpCharProperty.match
Product: platform Reporter: areeda <areeda>
Component: Output WindowAssignee: Martin Entlicher <mentlicher>
Status: VERIFIED FIXED QA Contact: issues <issues.netbeans.org>
Priority: P2 CC: arne_adams, jglick, lalbertme, mmirilovic, mperezma, musilt2, peathal, vladd
Version: 7.0   
Target Milestone: 7.0.1   
Hardware: All   
OS: All   
Whiteboard: EXCEPTIONS_REPORT, 70patch1-verified
Issue Type: DEFECT Exception Report: 177958
Bug Depends on:    
Bug Blocks: 192779    
Attachments: stacktrace

Description areeda 2011-03-26 16:54:39 UTC
Build: NetBeans IDE Dev (Build 201103260400)
VM: Java HotSpot(TM) 64-Bit Server VM, 19.1-b02, Java(TM) SE Runtime Environment, 1.6.0_24-b07
OS: Linux

User Comments:
areeda: OK it's real.

to duplicate create a new Java Application project and have the main method be:

    public static void main(String[] args)
    {
        System.out.print("\u001B[2K "+"   159B of  0.1 KB/s");
    }




Stacktrace: 
java.lang.StackOverflowError
   at java.util.regex.Pattern$BmpCharProperty.match(Pattern.java:3366)
   at java.util.regex.Pattern$Curly.match0(Pattern.java:3760)
   at java.util.regex.Pattern$Curly.match(Pattern.java:3744)
   at java.util.regex.Pattern$GroupHead.match(Pattern.java:4168)
   at java.util.regex.Pattern$Branch.match(Pattern.java:4114)
   at java.util.regex.Pattern$Slice.match(Pattern.java:3482)
Comment 1 areeda 2011-03-26 16:54:43 UTC
Created attachment 107298 [details]
stacktrace
Comment 2 Marian Mirilovic 2011-03-27 07:13:41 UTC
*** Bug 197112 has been marked as a duplicate of this bug. ***
Comment 3 mperezma 2011-03-27 21:28:56 UTC
*** Bug 197130 has been marked as a duplicate of this bug. ***
Comment 4 Jiri Kovalsky 2011-03-28 12:00:45 UTC
For the record, I was not able to reproduce it with NetBeans IDE 7.0 RC1 (Build 201103280000) and JDK 1.6.0_24 on my Linux Mint 10. IDE ran the application successfully and did not crash.
Comment 5 Jiri Kovalsky 2011-03-28 12:10:25 UTC
The problem with the NetBeans output window still persists though.
Comment 6 Martin Entlicher 2011-04-07 13:51:50 UTC
Reproduced. Thanks for the print expression.
Comment 7 Martin Entlicher 2011-04-07 15:27:08 UTC
The exception is fixed by changeset:   192177:fd30d4a29abb
http://hg.netbeans.org/main/rev/fd30d4a29abb

I've created issue #197540 to support more ANSI escape sequences.
\u001B[2K is currently not recognized, only coloring is implemented.
Comment 8 Quality Engineering 2011-04-08 08:52:05 UTC
Integrated into 'main-golden', will be available in build *201104080400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/fd30d4a29abb
User: mentlicher@netbeans.org
Log: #197114 Ignore unknown escape sequences.
Comment 9 Martin Entlicher 2011-05-13 13:40:09 UTC
*** Bug 198360 has been marked as a duplicate of this bug. ***
Comment 10 Martin Entlicher 2011-05-13 13:41:58 UTC
*** Bug 198150 has been marked as a duplicate of this bug. ***
Comment 11 Martin Entlicher 2011-05-13 19:28:51 UTC
*** Bug 198079 has been marked as a duplicate of this bug. ***
Comment 12 Martin Entlicher 2011-05-13 19:30:52 UTC
Increasing to P2 due to many duplicates.
It should go to the 70 patch, mainly because of issue #198079.
Comment 13 Martin Entlicher 2011-05-13 19:36:12 UTC
In behalf of comment https://netbeans.org/bugzilla/show_bug.cgi?id=198079#c35 I'm marking this as verified so that it can be included in the 70 patch:

------- Comment #35 From soldatov 2011-05-05 08:21:19 (-) [reply] ------- 
Output works nicely in trunk, but empty in NetBeans 7.0 from www.netbeans.org
Comment 14 Martin Entlicher 2011-05-16 15:05:48 UTC
Integrated in release70_fixes:
changeset:   190995:f4709ce6f343,
changeset:   190997:868018d2dbd1
http://hg.netbeans.org/releases/rev/f4709ce6f343
http://hg.netbeans.org/releases/rev/868018d2dbd1
Comment 15 Marian Mirilovic 2011-05-17 10:01:49 UTC
*** Bug 198030 has been marked as a duplicate of this bug. ***
Comment 16 Tomas Danek 2011-05-20 07:05:22 UTC
works fine now in 70patch1
By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo