Bug 197130 - [70cat] StackOverflowError at java.util.regex.Pattern$BmpCharProperty.match
[70cat] StackOverflowError at java.util.regex.Pattern$BmpCharProperty.match
Status: CLOSED DUPLICATE of bug 197114
Product: platform
Classification: Unclassified
Component: Output Window
7.0.1
All All
: P3 (vote)
: 7.0
Assigned To: issues@platform
issues@platform
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-27 20:57 UTC by mperezma
Modified: 2011-03-28 08:15 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (69.93 KB, text/plain)
2011-03-27 20:58 UTC, mperezma
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mperezma 2011-03-27 20:57:59 UTC
Build: NetBeans IDE Dev (Build 201103260400)
VM: Java HotSpot(TM) Client VM, 17.0-b16, Java(TM) SE Runtime Environment, 1.6.0_21-b06
OS: Linux

User Comments:
mperezma: I've been able to reproduce issue #498861:

Create a new java application and have the main method be:

    public static void main(String[] args)
    {
        System.out.print("\u001B[2K "+"   159B of  0.1 KB/s\r");
    }




Stacktrace: 
java.lang.StackOverflowError
   at java.util.regex.Pattern$BmpCharProperty.match(Pattern.java:3366)
   at java.util.regex.Pattern$BranchConn.match(Pattern.java:4078)
   at java.util.regex.Pattern$GroupTail.match(Pattern.java:4227)
   at java.util.regex.Pattern$Loop.matchInit(Pattern.java:4316)
   at java.util.regex.Pattern$Prolog.match(Pattern.java:4251)
   at java.util.regex.Pattern$Curly.match0(Pattern.java:3789)
Comment 1 mperezma 2011-03-27 20:58:04 UTC
Created attachment 107315 [details]
stacktrace
Comment 2 mperezma 2011-03-27 21:28:56 UTC

*** This bug has been marked as a duplicate of bug 197114 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo