Bug 198360 - StackOverflowError in OutWriter for printANSI
StackOverflowError in OutWriter for printANSI
Status: RESOLVED DUPLICATE of bug 197114
Product: platform
Classification: Unclassified
Component: Output Window
7.0.1
PC Linux
: P3 (vote)
: 7.0.1
Assigned To: Martin Entlicher
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-05 21:19 UTC by peathal
Modified: 2011-05-13 13:40 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description peathal 2011-05-05 21:19:35 UTC
I printed by accident a binary value via sout and NetBeans nearly crashed but at the end it printed the following message:

   java.lang.StackOverflowError
	at java.util.regex.Pattern$Curly.match(Pattern.java:3737)
	at java.util.regex.Pattern$GroupHead.match(Pattern.java:4168)
	at java.util.regex.Pattern$Branch.match(Pattern.java:4114)
	at java.util.regex.Pattern$Slice.match(Pattern.java:3482)
	at java.util.regex.Pattern$Start.match(Pattern.java:3055)
	at java.util.regex.Matcher.search(Matcher.java:1105)
	at java.util.regex.Matcher.find(Matcher.java:535)
	at org.netbeans.core.output2.OutWriter.printANSI(OutWriter.java:531)
	at org.netbeans.core.output2.OutWriter.print(OutWriter.java:480)
	at org.netbeans.core.output2.OutWriter.printANSI(OutWriter.java:578)
	at org.netbeans.core.output2.OutWriter.print(OutWriter.java:480)
	at org.netbeans.core.output2.OutWriter.printANSI(OutWriter.java:578)

(get this image via bufferedreader and print it 'as text': http://grfx.cstv.com/schools/okla/graphics/auto/20110505_schedule.jpg)
Comment 1 Martin Entlicher 2011-05-13 13:40:09 UTC
It should be already fixed by http://hg.netbeans.org/main/rev/fd30d4a29abb
Please try a newer dev build.

*** This bug has been marked as a duplicate of bug 197114 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo