Bug 198030 - StackOverflowError at java.util.regex.Pattern$GroupHead.match
StackOverflowError at java.util.regex.Pattern$GroupHead.match
Status: RESOLVED DUPLICATE of bug 197114
Product: platform
Classification: Unclassified
Component: Output Window
7.0
All All
: P3 with 1 vote (vote)
: 7.0.1
Assigned To: Martin Entlicher
issues@platform
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-23 00:05 UTC by lalbertme
Modified: 2011-05-17 10:01 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (69.93 KB, text/plain)
2011-04-23 00:05 UTC, lalbertme
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lalbertme 2011-04-23 00:05:16 UTC
This issue was reported manually by lalbertme.
It already has 1 duplicates 


Build: NetBeans IDE 7.0 (Build 201104080000)
VM: Java HotSpot(TM) Client VM, 19.1-b02, Java(TM) SE Runtime Environment, 1.6.0_24-b07
OS: Linux

User Comments:
lalbertme: Running Java Application project




Stacktrace: 
java.lang.StackOverflowError
   at java.util.regex.Pattern$GroupHead.match(Pattern.java:4168)
   at java.util.regex.Pattern$Loop.matchInit(Pattern.java:4314)
   at java.util.regex.Pattern$Prolog.match(Pattern.java:4251)
   at java.util.regex.Pattern$Curly.match0(Pattern.java:3789)
   at java.util.regex.Pattern$Curly.match(Pattern.java:3744)
   at java.util.regex.Pattern$GroupHead.match(Pattern.java:4168)
Comment 1 lalbertme 2011-04-23 00:05:21 UTC
Created attachment 107912 [details]
stacktrace
Comment 2 lalbertme 2011-04-23 00:27:56 UTC
Here is the problem:

// System.out.println((char) 27 + "[2J");

BTW, Netbeans 6.9.1 can handle this...
Comment 3 Marian Mirilovic 2011-05-17 10:01:49 UTC

*** This bug has been marked as a duplicate of bug 197114 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo