Bug 98870 - Enable Background updates
Enable Background updates
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Plugin Manager
5.x
All All
: P2 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@platform
plan61
: PLAN, UI
: 125161 126541 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-24 06:38 UTC by belur_1d
Modified: 2008-02-02 09:17 UTC (History)
4 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description belur_1d 2007-03-24 06:38:32 UTC
Hi 

It wud be nice to have "Run in background" button on Update window .
So we can continue working while nb updates itself. RIght now it blocks
main window.

Also one suggestion:

In case user selects many modules to install, nb prompts the user
that many times to accept licence. Is it possible for nb
to show one window only and have checkboxes for all those modules
wheere the user can choose not to accept the licence or not.

You can add a preview licence button next to checkbox.


Why am i asking this..because every time i just keep clicking
on the accept buttons because I want those modules.


-swaroop belur
Comment 1 belur_1d 2007-03-24 06:41:40 UTC
Also I would like the the checkboxes to be checked initially.
[i think it is sensible default because  i would like to install those
modules and am not sure whether this is right or not.. is it right to
say that these modules have one of those of pre requisite licences
which netbeans requires a modules writer to have before submitting one.

I mean some licence like GPL etc.

I think u get my point



Comment 2 jrojcek 2007-06-12 16:53:11 UTC
Agreed with all points. 

The update wizard should not block the user from working with the IDE while downloading and updating is in progress. Not sure how to do it exactly in the 
UI.
Comment 3 ehucka 2007-06-29 09:47:15 UTC
Preparing of update and finishing (restart etc.) should be always modal but there is no reason why to hold downloading
progress modal. 
I think nobody need to count percents till something is downloaded. There can be much important work to do in IDE. :)
Comment 4 Jiri Rechtacek 2008-01-08 11:47:21 UTC
Integrated into main trunk.

Checking in org/netbeans/modules/autoupdate/ui/wizards/UninstallStep.java;
/shared/data/ccvs/repository/autoupdate/ui/src/org/netbeans/modules/autoupdate/ui/wizards/UninstallStep.java,v  <-- 
UninstallStep.java
new revision: 1.14; previous revision: 1.13
done
Checking in org/netbeans/modules/autoupdate/ui/wizards/OperationPanel.java;
/shared/data/ccvs/repository/autoupdate/ui/src/org/netbeans/modules/autoupdate/ui/wizards/OperationPanel.java,v  <-- 
OperationPanel.java
new revision: 1.5; previous revision: 1.4
done
Checking in org/netbeans/modules/autoupdate/ui/wizards/Bundle.properties;
/shared/data/ccvs/repository/autoupdate/ui/src/org/netbeans/modules/autoupdate/ui/wizards/Bundle.properties,v  <-- 
Bundle.properties
new revision: 1.27; previous revision: 1.26
done
Checking in org/netbeans/modules/autoupdate/ui/wizards/OperationPanel.form;
/shared/data/ccvs/repository/autoupdate/ui/src/org/netbeans/modules/autoupdate/ui/wizards/OperationPanel.form,v  <-- 
OperationPanel.form
new revision: 1.3; previous revision: 1.2
done
Checking in org/netbeans/modules/autoupdate/ui/wizards/InstallStep.java;
/shared/data/ccvs/repository/autoupdate/ui/src/org/netbeans/modules/autoupdate/ui/wizards/InstallStep.java,v  <-- 
InstallStep.java
new revision: 1.20; previous revision: 1.19
done
Checking in org/netbeans/modules/autoupdate/ui/wizards/InstallUnitWizardModel.java;
/shared/data/ccvs/repository/autoupdate/ui/src/org/netbeans/modules/autoupdate/ui/wizards/InstallUnitWizardModel.java,v
 <--  InstallUnitWizardModel.java
new revision: 1.19; previous revision: 1.18
done
Checking in org/netbeans/modules/autoupdate/ui/wizards/NetworkProblemNotification.java;
/shared/data/ccvs/repository/autoupdate/ui/src/org/netbeans/modules/autoupdate/ui/wizards/NetworkProblemNotification.java,v
 <--  NetworkProblemNotification.java
new revision: 1.2; previous revision: 1.1
done
Checking in org/netbeans/modules/autoupdate/ui/wizards/CustomHandleStep.java;
/shared/data/ccvs/repository/autoupdate/ui/src/org/netbeans/modules/autoupdate/ui/wizards/CustomHandleStep.java,v  <-- 
CustomHandleStep.java
new revision: 1.8; previous revision: 1.7
done
Checking in org/netbeans/modules/autoupdate/ui/wizards/RestartNeededNotification.java;
/shared/data/ccvs/repository/autoupdate/ui/src/org/netbeans/modules/autoupdate/ui/wizards/RestartNeededNotification.java,v
 <--  RestartNeededNotification.java
new revision: 1.2; previous revision: 1.1
done
Checking in org/netbeans/modules/autoupdate/ui/Bundle.properties;
/shared/data/ccvs/repository/autoupdate/ui/src/org/netbeans/modules/autoupdate/ui/Bundle.properties,v  <-- 
Bundle.properties
new revision: 1.64; previous revision: 1.63
done
Checking in org/netbeans/modules/autoupdate/ui/InstallUnitWizard.java;
/shared/data/ccvs/repository/autoupdate/ui/src/org/netbeans/modules/autoupdate/ui/InstallUnitWizard.java,v  <-- 
InstallUnitWizard.java
new revision: 1.9; previous revision: 1.8
done
Checking in org/netbeans/modules/autoupdate/ui/UnitTab.java;
/shared/data/ccvs/repository/autoupdate/ui/src/org/netbeans/modules/autoupdate/ui/UnitTab.java,v  <--  UnitTab.java
new revision: 1.71; previous revision: 1.70
done
Checking in org/netbeans/modules/autoupdate/ui/PluginManagerUI.java;
/shared/data/ccvs/repository/autoupdate/ui/src/org/netbeans/modules/autoupdate/ui/PluginManagerUI.java,v  <-- 
PluginManagerUI.java
new revision: 1.41; previous revision: 1.40
done
Checking in org/netbeans/modules/autoupdate/ui/PluginManagerUI.form;
/shared/data/ccvs/repository/autoupdate/ui/src/org/netbeans/modules/autoupdate/ui/PluginManagerUI.form,v  <-- 
PluginManagerUI.form
new revision: 1.14; previous revision: 1.13
done
Checking in org/netbeans/modules/autoupdate/ui/resources/error.png;
/shared/data/ccvs/repository/autoupdate/ui/src/org/netbeans/modules/autoupdate/ui/resources/error.png,v  <--  error.png
new revision: 1.2; previous revision: 1.1
done
Checking in org/netbeans/modules/autoupdate/ui/actions/PluginManagerAction.java;
/shared/data/ccvs/repository/autoupdate/ui/src/org/netbeans/modules/autoupdate/ui/actions/PluginManagerAction.java,v 
<--  PluginManagerAction.java
new revision: 1.9; previous revision: 1.8
done
Checking in org/netbeans/modules/autoupdate/ui/actions/FlashingIcon.java;
/shared/data/ccvs/repository/autoupdate/ui/src/org/netbeans/modules/autoupdate/ui/actions/FlashingIcon.java,v  <-- 
FlashingIcon.java
new revision: 1.3; previous revision: 1.2
done
Checking in org/netbeans/modules/autoupdate/ui/actions/AutoupdateCheckScheduler.java;
/shared/data/ccvs/repository/autoupdate/ui/src/org/netbeans/modules/autoupdate/ui/actions/AutoupdateCheckScheduler.java,v
 <--  AutoupdateCheckScheduler.java
new revision: 1.15; previous revision: 1.14
done
Checking in META-INF/services/org.openide.awt.StatusLineElementProvider;
/shared/data/ccvs/repository/autoupdate/ui/src/META-INF/services/org.openide.awt.StatusLineElementProvider,v  <-- 
org.openide.awt.StatusLineElementProvider
new revision: 1.2; previous revision: 1.1
done
Comment 5 Jiri Rechtacek 2008-01-13 14:18:57 UTC
*** Issue 125161 has been marked as a duplicate of this issue. ***
Comment 6 dlipin 2008-02-02 09:17:15 UTC
*** Issue 126541 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo