Bug 97848 - I18N - Update modules (project types) to use FileEncodingQuery
I18N - Update modules (project types) to use FileEncodingQuery
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Generic Infrastructure
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Jesse Glick
issues@projects
plan60 nbide
: I18N, UMBRELLA
Depends on: 67340 97867 99345 42638 94676 97850 97851 97852 97854 97855 97861 97862 97866 97871 97872 97873 97878 99344 100178 100312 100807
Blocks: 89772
  Show dependency treegraph
 
Reported: 2007-03-14 15:54 UTC by Tomas Zezula
Modified: 2010-03-31 16:39 UTC (History)
3 users (show)

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Zezula 2007-03-14 15:54:58 UTC
The project types and some special modules need an update to use FileEncodingQuery. 
The project should provide the FileEncodingQueryImplementation in its Lookup and
the javac target in the build-impl.xml should use -encoding argument (see
j2seproject).
The most of DataObject should work as they are when they are derived from
DataEditorSupport, but if the project encoding shouldn't be used or the editor
is derived from CloneableEditorSupport the DataObject need an update (see
DataEditorSupport).
Some special modules which directly read|write the FileObject content should be
updated to use the correct encoding, for example search module.
Comment 1 Ken Frank 2007-03-29 00:13:19 UTC
should projects of enterprise, scripting, uml and other types of projects
or file types not covered by issues filed under this issue (see depends on issues) -

should their be tasks filed by developers of those projects  ?

Since its one nb6 now ?

If so, I can write the iteams of those areas if someone can tell me the wording
of what to say and ptrs to applicable issues and perhaps contact person they
can ask about it.

ken.frank@sun.com
Comment 2 Tomas Zezula 2007-03-29 09:01:31 UTC
Every project type should provide the FileEncodingQueryImplementation. There is
already an issue for j2ee project (enterprise). The scripting/schliemann should
be fine. The scripting/ruby has it's own project type I've added new issue: #99344.
The uml/project: #99345. If you know about some other project type not covered
by dependent issues create a task for it.
Comment 3 Ken Frank 2007-04-12 16:21:07 UTC
With state of this one as resolved, does it mean all depends on bugs are now
fixed/implemented ?


PS I created 100178 and 100312 on enterprise and visualweb; I'll create one
on identity in case something needs to be done with that.  

ken.frank@sun.com
Comment 4 Tomas Zezula 2007-04-12 18:25:44 UTC
The issue is not yet resolved, it contains opened dependent issues. This issue
will be resolved when all the dependent issues will be resolved.
Comment 5 Ken Frank 2007-07-11 17:52:01 UTC
added 67340 on css files and feq
Comment 6 Lukas Hasik 2008-04-10 21:41:55 UTC
moving opened issues from TM <= 6.1 to TM=Dev
Comment 7 Antonin Nebuzelsky 2010-03-29 14:10:19 UTC
Change of default owner.
Comment 8 Tomas Zezula 2010-03-29 14:22:31 UTC
The opened issues are from visualweb and uml. Probably fixed.
Comment 9 Tomas Zezula 2010-03-29 14:26:00 UTC
#97867 partially fixed by open|save in encoding (contrib/encoding).
Comment 10 Jesse Glick 2010-03-31 16:39:24 UTC
Close enough; no reason to have this open.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo