Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 97170 - Created file in New Java Package wizard shows wrong directory to be created when src/main/java missing
Created file in New Java Package wizard shows wrong directory to be created w...
Status: RESOLVED WONTFIX
Product: projects
Classification: Unclassified
Component: Maven
6.x
All All
: P3 (vote)
: TBD
Assigned To: Tomas Stupka
issues@platform
:
: 171030 (view as bug list)
Depends on: 102711
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-04 12:55 UTC by jlaskowski
Modified: 2016-07-07 08:38 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
NetBeans IDE 6.0m7's New Java Package with incorrect directory name (34.92 KB, image/png)
2007-03-04 12:56 UTC, jlaskowski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jlaskowski 2007-03-04 12:55:37 UTC
See the attached screenshot.
Comment 1 jlaskowski 2007-03-04 12:56:37 UTC
Created attachment 39154 [details]
NetBeans IDE 6.0m7's New Java Package with incorrect directory name
Comment 2 jlaskowski 2007-03-04 12:57:57 UTC
Also, the field name is 'Created File:' not 'Created Directory:'
Comment 3 Jan Lahoda 2007-03-22 09:27:37 UTC
I can reproduce with Maven "war" project, but cannot reproduce with J2SE project
of Maven "jar" or "hpi" project. Passing to Maven support to investigate.
Comment 4 Milos Kleint 2007-04-23 12:06:41 UTC
the problem is caused by the fact that war project archetype doesn't create
src/main/java folder which is the default source root for java packages. That
means no SourceGroup instance is created. That' what the wizard relies on. 
An obvious workaround is to create the src/main/java folder and reload the project.
Comment 5 Milos Kleint 2007-05-20 11:42:18 UTC
partially workarounded/fixed by creating the src/main/java and src/test/java
folders on creation of a new project. Won't influence behaviour of any existing
projects though.
Comment 6 Jaroslav Pospisil 2009-05-14 10:26:06 UTC
This issue seems to be already fixed,I can't reproduce it.
Comment 7 Milos Kleint 2009-05-14 10:41:22 UTC
it's still there, we just make sure to create src/main/java folder on project creation.. If you havea project without
it, you shall be able to reproduce.
Comment 8 Milos Kleint 2009-08-28 11:39:40 UTC
*** Issue 171030 has been marked as a duplicate of this issue. ***
Comment 9 Antonin Nebuzelsky 2010-04-08 12:05:48 UTC
Change of the default owner.
Comment 10 Martin Balin 2016-07-07 08:38:04 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo