Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 171030 - maven project adding new class problem
maven project adding new class problem
Status: RESOLVED DUPLICATE of bug 97170
Product: projects
Classification: Unclassified
Component: Maven
6.x
All All
: P3 (vote)
: TBD
Assigned To: Milos Kleint
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-27 19:40 UTC by kscarr
Modified: 2009-08-28 11:39 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kscarr 2009-08-27 19:40:31 UTC
Some maven archetypes do not create the src/main/java folder.  

If you use Netbeans, and try to add a class to this project, netbeans throws the file in the root of the project.  You
have to go to the Files tab to be able to see the file again.

If you create the src/main/java folder manually, then create the class, it puts the files in the project properly.
Comment 1 Milos Kleint 2009-08-28 11:39:40 UTC
a duplicate of #97170, if the archetype created from the IDE, we add the test and main java folders automatically to
avoid the problem. A manual workaround is to create the files (project reload or IDE restart might be necessary in this
case)

*** This issue has been marked as a duplicate of 97170 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo