Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 8617 - ability to hide workspace switcher
ability to hide workspace switcher
Status: CLOSED FIXED
Product: platform
Classification: Unclassified
Component: Window System
3.x
All All
: P2 (vote)
: 6.x
Assigned To: David Simonek
issues@platform
: UI
: 11889 (view as bug list)
Depends on: 22539
Blocks: 9940 17815 23399
  Show dependency treegraph
 
Reported: 2000-11-29 09:29 UTC by David Simonek
Modified: 2008-12-23 09:54 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Simonek 2000-11-29 09:29:31 UTC
For special uses of the IDE, workspace concept shouldn't be visible to the user.
It would be desirable to have ability to hide workspace switcher so that user is
not bothered with existence of workspaces.
Comment 1 Jan Chalupa 2001-05-05 20:30:41 UTC
Target milestone -> 3.3
Comment 2 Jan Chalupa 2001-11-27 11:52:21 UTC
Target milestone -> 3.3.1.
Comment 3 Jan Chalupa 2001-11-27 11:56:10 UTC
Target milestone -> 3.3.1.
Comment 4 Jan Chalupa 2002-01-11 14:02:42 UTC
Target milestone -> 3.4
Comment 5 Jan Chalupa 2002-01-11 14:06:18 UTC
Target milestone -> 3.4
Comment 6 Jan Chalupa 2002-01-11 14:07:42 UTC
Target milestone -> 3.4
Comment 7 Jan Chalupa 2002-01-11 14:10:49 UTC
Target milestone -> 3.4
Comment 8 David Simonek 2002-01-28 16:10:30 UTC
Reassigning to Peter. Peter, please go through and evaluate, thanks.
Comment 9 David Simonek 2002-01-29 14:39:45 UTC
*** Issue 11889 has been marked as a duplicate of this issue. ***
Comment 10 Peter Zavadsky 2002-01-29 14:55:20 UTC
The funcioanlity is there. It is needed just to decide how it should
look like. Whether some switch at starting, or new option should be
created. For ui.
Comment 11 Peter Zavadsky 2002-01-29 14:55:48 UTC
The funcioanlity is there. It is needed just to decide how it should
look like. Whether some switch at starting, or new option should be
created. For ui.
Comment 12 David Simonek 2002-02-12 13:18:52 UTC
- ui discussion which switcher should be default
- hide/show of switcher (and switcher type) will be manipulated
through instance file in toolbar layer
- try to make existing workspace switcher subclass of JToolbar, get
inspiration from combo switcher (if nbui decide not to go with new
combo switcher)
Comment 13 David Simonek 2002-02-20 18:03:04 UTC
Todo:
- add creation factory method for Workspaceswitcher, to be callable
from xml layer
- specify xml layer to put WSwitcher to toolbar
- remove harcoded wswitcher from main window
- modify xml layer for status line to be put into toolbar
- assure that option small_main_window works correctly (add handling)
- assure that switcher looks still the same (maybe we'll need to
implement JToolbar bridge to WorkspaceSwitcher)
Comment 14 David Simonek 2002-03-29 10:38:56 UTC
Sidenotes for implementation issues:

1) startup command option "netbeans.windows.nostatusline" is removed,
disabling of status line now can be done through regular toolbar
manipulation (e.g. disable toolbar called statusline)
2) startup command option "netbeans.windows.small_main_window"  works
as usual.
Comment 15 David Simonek 2002-03-29 14:41:11 UTC
implemented in main trunk.
Comment 16 dominic 2002-03-29 22:40:08 UTC
Is it possible to put the status bar at bottom by the 
layer file as well or is too much asking. Normally 
(specially on windows) ppl excpect the status bar to be at 
the bottom.
Comment 17 Jan Zajicek 2002-04-05 15:50:44 UTC
Implementation verified in the trunk builds.
Comment 18 David Simonek 2002-04-17 15:38:46 UTC
reopening, implementation rollbacked because of major problems from ui
prespective.
Comment 19 David Simonek 2002-04-17 18:09:04 UTC
tags around rollback:
toolbar_wsswitcher_before_rollback
toolbar_wsswitcher_after_rollback
Comment 20 David Simonek 2002-05-03 14:12:06 UTC
another try to fix #8617.
For IDE things remains the same, in platform there is possibility to
configure position, existence of workspace switcher and status line
through layers like for regular toolbars.
Comment 21 Jan Zajicek 2002-05-09 10:34:50 UTC
ok, verified
Comment 22 Quality Engineering 2003-07-01 16:51:20 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo