Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 58807 - Could not install some modules on start
Could not install some modules on start
Status: VERIFIED FIXED
Product: versioncontrol
Classification: Unclassified
Component: CVS library
5.x
All All
: P1 (vote)
: 5.x
Assigned To: _ pkuzel
issues@versioncontrol
:
: 58809 58812 (view as bug list)
Depends on: 19443
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-12 08:42 UTC by Marian Mirilovic
Modified: 2007-01-04 17:14 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
log file (35.79 KB, text/plain)
2005-05-12 08:45 UTC, Marian Mirilovic
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Mirilovic 2005-05-12 08:42:45 UTC
NB4.2 (200505111800), JDK1.5.0_03

just start IDE and dialog with next logs rises :


Warning - could not install some modules:
        CVS Client Library - No module providing the capability
org.openide.compiler.CompilationEngine could be found.        CVS Client Library
- No module providing the capability org.openide.TopManager could be found.
        CVS Client Library - The module named org.openide.compiler was needed
and not found.
        CVS Client Library - The module named org.openide.deprecated was needed
and not found.
        CVS Client Library - The module named org.openide.execution.deprecated
was needed and not found.
        CVS Support Profile - The module CVS Client Library would also need to
be installed.
Comment 1 Marian Mirilovic 2005-05-12 08:45:20 UTC
Created attachment 22104 [details]
log file
Comment 2 Peter Pis 2005-05-12 09:35:14 UTC
*** Issue 58809 has been marked as a duplicate of this issue. ***
Comment 3 Martin Entlicher 2005-05-12 10:27:44 UTC
Has nothing to do with vcscore.
Comment 4 Martin Entlicher 2005-05-12 10:28:54 UTC
Caused by:

User: pkuzel  
Date: 05/05/11 07:22:00

Modified:
 /javacvs/libmodule/nbproject/
  project.xml
 /ide/golden/
  deps.txt

Log:
 Dependency on openide is nonsense - removed.

File Changes:

Directory: /javacvs/libmodule/nbproject/
========================================

File [changed]: project.xml
Url:
http://javacvs.netbeans.org/source/browse/javacvs/libmodule/nbproject/project.xml?r1=1.2&r2=1.3
Delta lines:  +1 -10
--------------------
--- project.xml	28 Apr 2005 04:48:20 -0000	1.2
+++ project.xml	11 May 2005 14:21:57 -0000	1.3
@@ -16,16 +16,7 @@
     <configuration>
         <data xmlns="http://www.netbeans.org/ns/nb-module-project/2">
             <code-name-base>org.netbeans.lib.cvsclient</code-name-base>
-            <module-dependencies>
-                <dependency>
-                    <code-name-base>org.openide</code-name-base>
-                    <build-prerequisite/>
-                    <run-dependency>
-                        <release-version>1</release-version>
-                        <specification-version>4.20</specification-version>
-                    </run-dependency>
-                </dependency>
-            </module-dependencies>
+            <module-dependencies/>
             <public-packages>
                 <package>org.netbeans.lib.cvsclient</package>
                 <package>org.netbeans.lib.cvsclient.admin</package>

Directory: /ide/golden/
=======================

File [changed]: deps.txt
Url: http://ide.netbeans.org/source/browse/ide/golden/deps.txt?r1=1.64&r2=1.65
Delta lines:  +0 -2
-------------------
--- deps.txt	10 May 2005 13:40:30 -0000	1.64
+++ deps.txt	11 May 2005 14:21:58 -0000	1.65
@@ -81,8 +81,6 @@
 MODULE org.netbeans.jmi.javamodel/1 (ide)
   REQUIRES javax.jmi.reflect/1 (ide)
   REQUIRES org.openide/1 (platform)
-MODULE org.netbeans.lib.cvsclient/1 (ide)
-  REQUIRES org.openide/1 (platform)
 MODULE org.netbeans.libs.commons_logging/1 (ide)
   REQUIRES org.openide/1 (platform)
 MODULE org.netbeans.libs.j2eeeditor/1 (j2ee)
Comment 5 Martin Entlicher 2005-05-12 10:29:36 UTC
Fixed (hopefully):

User: pkuzel  
Date: 05/05/12 02:12:55

Modified:
 /javacvs/libmodule/nbproject/
  project.xml
 /ide/golden/
  deps.txt

Log:
 Rollback

File Changes:

Directory: /javacvs/libmodule/nbproject/
========================================

File [changed]: project.xml
Url:
http://javacvs.netbeans.org/source/browse/javacvs/libmodule/nbproject/project.xml?r1=1.3&r2=1.4
Delta lines:  +10 -1
--------------------
--- project.xml	11 May 2005 14:21:57 -0000	1.3
+++ project.xml	12 May 2005 09:12:52 -0000	1.4
@@ -16,7 +16,16 @@
     <configuration>
         <data xmlns="http://www.netbeans.org/ns/nb-module-project/2">
             <code-name-base>org.netbeans.lib.cvsclient</code-name-base>
-            <module-dependencies/>
+            <module-dependencies>
+                <dependency>
+                    <code-name-base>org.openide</code-name-base>
+                    <build-prerequisite/>
+                    <run-dependency>
+                        <release-version>1</release-version>
+                        <specification-version>4.20</specification-version>
+                    </run-dependency>
+                </dependency>
+            </module-dependencies>
             <public-packages>
                 <package>org.netbeans.lib.cvsclient</package>
                 <package>org.netbeans.lib.cvsclient.admin</package>

Directory: /ide/golden/
=======================

File [changed]: deps.txt
Url: http://ide.netbeans.org/source/browse/ide/golden/deps.txt?r1=1.65&r2=1.66
Delta lines:  +2 -0
-------------------
--- deps.txt	11 May 2005 14:21:58 -0000	1.65
+++ deps.txt	12 May 2005 09:12:52 -0000	1.66
@@ -81,6 +81,8 @@
 MODULE org.netbeans.jmi.javamodel/1 (ide)
   REQUIRES javax.jmi.reflect/1 (ide)
   REQUIRES org.openide/1 (platform)
+MODULE org.netbeans.lib.cvsclient/1 (ide)
+  REQUIRES org.openide/1 (platform)
 MODULE org.netbeans.libs.commons_logging/1 (ide)
   REQUIRES org.openide/1 (platform)
 MODULE org.netbeans.libs.j2eeeditor/1 (j2ee)
Comment 6 Peter Pis 2005-05-12 10:33:32 UTC
*** Issue 58812 has been marked as a duplicate of this issue. ***
Comment 7 Martin Entlicher 2005-05-12 10:33:36 UTC
*** Issue 58812 has been marked as a duplicate of this issue. ***
Comment 8 _ pkuzel 2005-05-12 10:47:34 UTC
In fact that is bug in core. cvsclient library does not need openide.
Unfortunatlly module system implementation does not count with libraries and
always adds dependecy on openide-deprecated.jar ...

<cite src=Jesse>
Careful - you cannot yet remove the dep on org.openide because ModuleAutoDeps
will add back in not only openide, but also deprecated APIs! What you are
waiting for - which is not yet available - is described in the last section of

http://openide.netbeans.org/proposals/arch/modularize.html
</cite>
Comment 9 Peter Pis 2005-05-13 07:36:12 UTC
Now it's ok. Can you set it as verified, please?
Comment 10 Marian Mirilovic 2005-05-13 09:29:54 UTC
I am used to verify my issues ;)
verified in NB4.2 (200505121800)
Comment 11 Peter Pis 2005-05-13 09:42:14 UTC
I know, thanks for immediate verifying. 


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo