Bug 58263 - Open of projects blocks EQ
Open of projects blocks EQ
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Generic Projects UI
5.x
All All
: P3 (vote)
: 5.x
Assigned To: Jan Lahoda
issues@projects
: PERFORMANCE, THREAD
: 59097 59682 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-25 08:23 UTC by _ rkubacki
Modified: 2005-11-08 13:46 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stack of event dispatch thread (5.21 KB, text/plain)
2005-04-25 08:24 UTC, _ rkubacki
Details
another stack trace (4.26 KB, text/plain)
2005-08-12 13:35 UTC, _ rkubacki
Details

Note You need to log in before you can comment on or make changes to this bug.
Description _ rkubacki 2005-04-25 08:23:20 UTC
dev build from Apr 22 

Open required projects action can be slow and it runs in AWT thread. It means
that UI is frozen if the user calls this action and it has to open several
projects. This is well visible with NB projects where we have many dependencies.
Comment 1 _ rkubacki 2005-04-25 08:24:49 UTC
Created attachment 21845 [details]
stack of event dispatch thread
Comment 2 Jesse Glick 2005-04-25 18:23:37 UTC
I guess it should show a progress dialog or something?
Comment 3 _ rkubacki 2005-04-25 19:13:24 UTC
Probably. It might be risky to allow user interaction during this time.
Comment 4 Antonin Nebuzelsky 2005-04-26 09:30:33 UTC
I added this action to the list of progress indication API/UI usecases for F.
Comment 5 Jesse Glick 2005-05-20 19:33:52 UTC
*** Issue 59097 has been marked as a duplicate of this issue. ***
Comment 6 Jesse Glick 2005-06-07 08:12:35 UTC
*** Issue 59682 has been marked as a duplicate of this issue. ***
Comment 7 _ rkubacki 2005-08-12 13:32:59 UTC
Applies to project open action as well as to open required projects and looks
bad when the count/size of projects is bigger.
Comment 8 _ rkubacki 2005-08-12 13:35:26 UTC
Created attachment 23760 [details]
another stack trace
Comment 9 _ rkubacki 2005-08-12 13:37:20 UTC
I attached another stack trace - NBM projects is updating classpath from
NbModuleProject$OpenedHook.projectOpened. This can be specific for apisupport
projects.
Comment 10 Jan Lahoda 2005-11-08 13:46:12 UTC
Should be fixed as part of issue #65349.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo