Bug 48427 - [60cat] Integrate Refactoring Undo with Editor Undo
[60cat] Integrate Refactoring Undo with Editor Undo
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Refactoring
4.x
PC Windows ME/2000
: P3 with 1 vote (vote)
: 7.2
Assigned To: Jan Becicka
issues@java
: PLAN, UI
: 108521 116228 118236 129365 164181 176733 203255 205118 (view as bug list)
Depends on: 205283 207174 207949
Blocks: 99870 75769 88071 88147 98970 138591
  Show dependency treegraph
 
Reported: 2004-09-02 22:24 UTC by Chris Kutler
Modified: 2012-03-21 12:04 UTC (History)
5 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Current progress... (144.36 KB, patch)
2012-03-09 15:29 UTC, Jan Becicka
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Kutler 2004-09-02 22:24:16 UTC
[ BUILD # : Beta 1 ]
[ JDK VERSION : J2SE 1.5.0 ]

After doing a refactoring action, one should be able to undo that action. However, Undo is disabled in the Edit menu.
Comment 1 Martin Matula 2004-09-02 22:35:58 UTC
Try Refactor->Undo.
We know single undo action would be better, but we were not able to
integrate them for this release. Changing summary and issue type to
ENHANCEMENT.
Comment 2 Martin Matula 2004-11-09 13:00:17 UTC
We should try to integrate this in 4.1.
Comment 3 Jan Becicka 2006-11-22 13:59:47 UTC
I try to do it for 6.0
Comment 4 Jan Becicka 2006-11-29 09:21:34 UTC
We need to implement refactoring undo using local history and integrate it with
editor undo.
Comment 5 Jan Becicka 2007-01-17 19:34:01 UTC
I implemented Undo without Local History.
Comment 6 Jan Becicka 2007-01-17 19:35:34 UTC
We probably don't integrate it for 6.0
Comment 7 Jan Becicka 2007-07-16 09:07:12 UTC
*** Issue 108521 has been marked as a duplicate of this issue. ***
Comment 8 Jan Becicka 2007-09-21 10:45:17 UTC
*** Issue 116228 has been marked as a duplicate of this issue. ***
Comment 9 Jan Becicka 2007-10-09 15:08:26 UTC
*** Issue 118236 has been marked as a duplicate of this issue. ***
Comment 10 Jan Becicka 2008-03-13 15:00:31 UTC
*** Issue 129365 has been marked as a duplicate of this issue. ***
Comment 11 Jan Pokorsky 2009-09-29 15:16:23 UTC
*** Issue 164181 has been marked as a duplicate of this issue. ***
Comment 12 Jan Pokorsky 2009-11-16 05:16:14 UTC
*** Bug 176733 has been marked as a duplicate of this bug. ***
Comment 13 Jan Becicka 2011-10-07 06:46:40 UTC
*** Bug 203255 has been marked as a duplicate of this bug. ***
Comment 14 Marian Mirilovic 2011-10-07 07:26:17 UTC
Honza, do you still plan to fix it for NB 7.1  ?
Comment 15 Jan Becicka 2011-10-07 07:35:13 UTC
this is very complex task. Not doable for 7.1
Comment 16 Jan Becicka 2011-11-15 06:18:25 UTC
*** Bug 205118 has been marked as a duplicate of this bug. ***
Comment 17 Jan Becicka 2012-03-09 15:29:31 UTC
Created attachment 116515 [details]
Current progress...
Comment 18 Jan Becicka 2012-03-20 09:25:13 UTC
Changeset: e7f98ee45ecc
Author:    Jan Becicka <jbecicka@netbeans.org>
Date:      2012-03-20 10:00
Message:   #209110:  API Addition: RefactoringCommit, Modification Result
Issue #48427 - [60cat] Integrate Refactoring Undo with Editor Undo and Local History
Comment 19 Jan Becicka 2012-03-20 09:59:23 UTC
Integration with Local History filed as issue 209778
Comment 20 Quality Engineering 2012-03-21 12:04:44 UTC
Integrated into 'main-golden', will be available in build *201203210400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/e7f98ee45ecc
User: Jan Becicka <jbecicka@netbeans.org>
Log: #209110:  API Addition: RefactoringCommit, Modification Result
Issue #48427 - [60cat] Integrate Refactoring Undo with Editor Undo and Local History


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo