Bug 205118 - UNDO/REDO functionality is not working after using Refactoring
UNDO/REDO functionality is not working after using Refactoring
Status: RESOLVED DUPLICATE of bug 48427
Product: java
Classification: Unclassified
Component: Refactoring
7.1
PC Windows 7
: P3 (vote)
: TBD
Assigned To: Jan Becicka
issues@java
: PLATFORM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-14 20:53 UTC by jannavratil
Modified: 2011-11-15 10:54 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jannavratil 2011-11-14 20:53:46 UTC
Undo and Redo functionality doesn't work after using any Refactoring function.

How to reproduce this bug: Pick function name and rename it using Refactoring->Rename. Undo button is grey, so user can't rollback changes

Redo doesn't work basically because we can't use Undo function :-(

Product Version: NetBeans IDE Dev (Build 201111130600)
Java: 1.7.0; Java HotSpot(TM) Client VM 21.0-b17
System: Windows 7 version 6.1 running on x86; Cp1252; en_US (nb)
User directory: C:\Users\navratja\.netbeans\dev
Cache directory: C:\Users\navratja\.netbeans\dev\var\cache
Comment 1 Jan Becicka 2011-11-15 06:18:25 UTC
please use Refactoring | Undo

*** This bug has been marked as a duplicate of bug 48427 ***
Comment 2 jannavratil 2011-11-15 10:54:33 UTC
Sorry, my mistake :-(

Yes it works


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo