Bug 46826 - Menu stays highlighted when switch with Alt+Tab
Menu stays highlighted when switch with Alt+Tab
Status: CLOSED WONTFIX
Product: platform
Classification: Unclassified
Component: Window System
4.x
PC Windows XP
: P2 (vote)
: 4.x
Assigned To: David Simonek
issues@platform
: FOCUS
: 65748 71552 139895 140236 166964 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-02 12:47 UTC by cezariusz
Modified: 2009-11-09 11:11 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description cezariusz 2004-08-02 12:47:41 UTC
I'm often using Alt+Tab to switch between apps. 
When I switch form NetBeans to an other app, 
IDE's menu stays highlighted, so when I go back 
to NetBeans I cannot type until I press Esc or 
Alt to exit from the menu.
It doesn't happen when you switch slowly and 
after switching you release Tab and then Alt.

Steps to reproduce:
1. When NetBeans IDE is active press and keep Alt
2. Press Tab to switch to an other app
3. Release Alt, then release Tab
If the second app's window is smaller than IDE 
you will see, that File menu of NetBeans is 
highlighted. When you switch back to IDE 
(doesn't matter how, even with mouse on the 
taskbar), you'll see the File is still 
highlighted and you cannot type in a text editor.
Comment 1 David Simonek 2004-08-02 13:45:48 UTC
Thx for report, however it's duplicate of 42954 and 42113.
Unfortunately it looks like I can't do anything to fix this issue
(it's Swing's LF issue), but at least I'll try to find out what is
happening behind the scenes.

*** This issue has been marked as a duplicate of 42113 ***
Comment 2 David Simonek 2004-08-02 13:46:17 UTC
closed by mistake.
Comment 3 cezariusz 2004-08-09 14:06:04 UTC
This seems to be very common and annoying. See the following reports:
issue 13163
issue 16481
issue 16755
issue 37554
issue 42954
issue 42113
issue 42499
Isn't that a reason to raise priority?
Comment 4 Milos Kleint 2004-08-09 15:04:37 UTC
I've read all the issues you point to and it seems that it's been
repeatedly evaluates as jdk bug, not netbeans.

http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=4841881

We can hardly do anything about it. closing as won't fix.
Comment 5 cezariusz 2004-08-10 14:54:03 UTC
OK, you forced me to install JDK 1.5 beta 2 and it solved the 
problem.
Comment 6 bojanbb 2004-12-15 14:35:16 UTC
Switch NetBeans to Metal look and feel, and the problem will 
disappear. And Metal looks better anyway.
Comment 7 David Simonek 2005-10-12 16:01:28 UTC
*** Issue 65748 has been marked as a duplicate of this issue. ***
Comment 8 David Simonek 2006-01-23 17:32:26 UTC
*** Issue 71552 has been marked as a duplicate of this issue. ***
Comment 9 _ hong_lin 2008-07-22 23:23:10 UTC
*** Issue 140236 has been marked as a duplicate of this issue. ***
Comment 10 Jiri Prox 2008-07-28 10:31:51 UTC
*** Issue 139895 has been marked as a duplicate of this issue. ***
Comment 11 Petr Dvorak 2009-11-09 11:11:35 UTC
*** Bug 166964 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo