Bug 41258 - [SDI] Project and Files tab doesn't receive focus after switch to it
[SDI] Project and Files tab doesn't receive focus after switch to it
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Generic Projects UI
4.x
PC All
: P3 (vote)
: 5.x
Assigned To: Jan Lahoda
issues@projects
: A11Y, FOCUS
: 39836 66068 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-24 11:51 UTC by sebastianm
Modified: 2005-10-11 16:05 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sebastianm 2004-03-24 11:51:43 UTC
Unlike "Select Document Node in -> FileSystems"
"Select Document Node in -> Project" does NOT
transfer the focus to the project view although it
is being highlighted, which is annoying since you
have to use the mouse in order to navigate through
the Project View.
Comment 1 Lukas Hasik 2004-03-24 15:01:49 UTC
the same happens when you just switch to Project tab. Focus is
'somewhere' and you need one more click into tree to start navigation
by keyboard.
Comment 2 Lukas Hasik 2004-03-25 10:18:04 UTC
changing summary to express better what's about.
TM=promo-D
Comment 3 Lukas Hasik 2004-03-25 10:40:29 UTC
*** Issue 39836 has been marked as a duplicate of this issue. ***
Comment 4 Milos Kleint 2004-06-14 13:15:31 UTC
in build 20040613 switching to projects tab doesn't work at all.
Comment 5 Milos Kleint 2004-06-14 13:59:17 UTC
correction.
it works for j2se project type, is not working for netbeans project
(apisupport) type where it's not implemented -> works for the
supported usecase.
the current 4.0 projects tab is a different component than the 3.6
projects tab so the issue got fixed during the rewrite probably. All
components beaving the same way now (Projects/Files/Favourites/Versioning)

Comment 6 Milos Kleint 2004-08-03 13:15:56 UTC
actually after fixing #41681 it should not happen at all. please try
in to verify in builds after 4/8/2004.
Comment 7 Zdenek Konecny 2005-07-13 15:20:29 UTC
Closed. It's too old.
Comment 8 bht 2005-07-13 21:57:00 UTC
Hi,
I use the 4.1 IDE and it's still there. Maybe it is not in the latest build
which I haven't tried. I can reproduce it as follows:

In SDI mode, I am in the Explorer window, full screen.
When I Use [Alt+arrow] to switch between tabs, then the highlighted tree nodes
cannot get focus with the keyboard unless I click on them once again with the
mouse. The bug is in the Files and the Project tabs but not in the Favorite and
Runtime tabs. 
Comment 9 David Simonek 2005-09-20 16:21:55 UTC
Yes, confirmed, scenario from user bht is fully reproductible. Passing to
projects, where Projects and Files components belong.
Comment 10 Jesse Glick 2005-09-21 00:00:33 UTC
Dafe, is there some documented code snippet you need to use in your TC impl to
make this work correctly? If so, does the TC impl template in apisupport/project
do it correctly? If not, could you file a bug report with details to correct it?
Comment 11 Jan Lahoda 2005-09-21 15:25:05 UTC
Should be fixed in the trunk:
Checking in src/org/netbeans/modules/project/ui/ProjectTab.java;
/cvs/projects/projectui/src/org/netbeans/modules/project/ui/ProjectTab.java,v 
<--  ProjectTab.java
new revision: 1.29; previous revision: 1.28
done
Comment 12 Jesse Glick 2005-09-21 22:37:09 UTC
So you're supposed to override *both* requestFocus() and requestFocusInWindow()?
Or what?
Comment 13 Milos Kleint 2005-09-22 06:36:46 UTC
yes. requestfocus is used in sdi and RFInWindow is used in mdi. 
actually it's qute convenienet that the bug was fixed now, as I figured that the
only workaround for #60235 to work on macosx in 1.5 is to call requestFocus()
instead of requestFocusInWindow
Comment 14 Jan Lahoda 2005-10-11 16:05:34 UTC
*** Issue 66068 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo