Bug 39836 - Project window content does not retain focus when window gains focus
Project window content does not retain focus when window gains focus
Status: VERIFIED DUPLICATE of bug 41258
Product: platform
Classification: Unclassified
Component: Explorer
3.x
PC Windows 95/98
: P2 (vote)
: 4.x
Assigned To: Jiri Rechtacek
issues@platform
SDI
: FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-09 23:02 UTC by bht
Modified: 2008-12-22 23:05 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bht 2004-02-09 23:02:40 UTC
In SDI mode, window content, i.e. file system
nodes do not re-gain focus
after switching from and to the project window.
It is possible to focus with the mouse, but not
with the keyboard.
This reproduces always with the following testcase.


Product Version  = NetBeans IDE Dev (Build
200401301900)
Operating System = Windows 98 version 4.10 running
on x86
Java; VM; Vendor = 1.4.2_03; Java HotSpot(TM)
Client VM 1.4.2_03-b02


How to reproduce:

- Create an empty userDir
- Start NetBeans
- Menu|Tools|Setup Wizard|Separate Windows Mode|Finish
- Maximise the NetBeans IDE Toolbar window
- Maximise the FileSystems Window
- Maximise the Editor Window
- Menu|Window|Project
- In the Project frame inside the Explorer window,
locate on "Project Default"
- Rigt click, "Add Existing..."
- Select sampledir, click OK
- In the Project frame inside the Explorer window,
locate on "sampledir" to ensure it has forus
- Press [Ctrl+left arrow] to open the Filesystems
frame inside the enclosing window.
- Press [Ctrl+right arrow] to go back to the
project frame.
  - "sampledir" has lost focus
- Try any keyboard action e.g. repeated [Tab] to
give focus to "sampledir"
  - Still no focus
Comment 1 Jaroslav Tulach 2004-02-12 13:48:21 UTC
Sorry for bothering again Tim, I was looking thru our not-yet-evaluated bugs and
found out that you own ten of them. As release 3.6 criteria is to have all of
them evaluated (as well as to not have any P1, P2), could you please look at
these bugs and set the target milestone to something else than TBD? Thanks in
advance and one again, sorry for bothering.
Comment 2 Jiri Rechtacek 2004-02-13 16:00:59 UTC
The last comment leads me to feeling that not addresed to me but to
Tim, changed subcompoment to any Tim's. Tim, if I'm wrong feel free to
reassign back to me.
Comment 3 Jiri Rechtacek 2004-02-13 16:01:28 UTC
The last comment leads me to feeling that not addressed to me but to
Tim, changed subcomponent to any Tim's. Tim, if I'm wrong feel free
reassign back to me.
Comment 4 _ tboudreau 2004-02-13 16:10:30 UTC
Ignore the last comment, it's just Jarda being obnoxious :-)

Jirka, I reassigned it to you because it's a focus issue with an explorer view, the project 
tab, and is probably very close to (if not fixed by) the code touched by your fix for the 
menu problem when opening a new project.  If you want, I'll look at it, but you know this 
code better.
Comment 5 _ tboudreau 2004-02-20 12:10:00 UTC
Giving this issue back to Jirka.  If only reproducible on Win98, possibly close as wontfix.
Comment 6 bht 2004-03-24 20:30:17 UTC
Has anybody tried this testcase?

This error does not occur in earlier versions of the IDE, consequently
it is a deterioration. Why is this getting a target milestone of future?

I am raising the priority because I feel that overall, in SDI mode,
the quality of the IDE has deteriorated dramatically.

For that reason, I am using an old version from before the majot GUI
changes in my daily work.
Comment 7 Lukas Hasik 2004-03-25 10:40:31 UTC
duplicate - issue 41258 is more generic.


*** This issue has been marked as a duplicate of 41258 ***
Comment 8 Marian Mirilovic 2004-03-25 22:41:37 UTC
verified duplicate


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo