Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 108861 - Problematic in-place editing of watches
Problematic in-place editing of watches
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: Outline&TreeTable
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Stanislav Aubrecht
issues@platform
:
Depends on: 33281
Blocks: 37757
  Show dependency treegraph
 
Reported: 2007-07-04 13:01 UTC by Martin Entlicher
Modified: 2008-12-22 10:21 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Entlicher 2007-07-04 13:01:45 UTC
In order to be able to modify a watch expression in-place, or add a new watch expression into the empty slot, it's
necessary to click into the expression table cell several times.
The cell should go into the editing mode as soon as a letter is written, or at least after a single click, like cells in
the explorer.
Comment 1 Roman Ondruska 2007-08-29 17:19:15 UTC
This feature is likely to be dropped from NB 6 and planned for the next release.
Comment 2 Martin Entlicher 2007-09-20 17:33:40 UTC
Due to the bugs associated with this implementation, we're going to remove the last empty line and the possibility to
in-place edit watches expressions. :-(

The in-place editing bug is a bug of Tree Table View, thus I'm moving this there.

I'll return the in-place editing functionality into debugger after it's fixed in TTV.
Moving to openide/tree table view.
Comment 3 Stanislav Aubrecht 2007-10-03 10:34:48 UTC
and how can i reproduce this bug?
Comment 4 Martin Entlicher 2007-10-03 14:01:08 UTC
You can activate in-place editing of watches in debugger by applying this simple patch:
Then start debugger, add something into Watches window and try to edit in-place the watch expression.

Index: debuggerjpda/ui/src/org/netbeans/modules/debugger/jpda/ui/models/WatchesNodeModel.java
===================================================================
RCS file:
/shared/data/ccvs/repository/debuggerjpda/ui/src/org/netbeans/modules/debugger/jpda/ui/models/WatchesNodeModel.java,v
retrieving revision 1.19
retrieving revision 1.18
diff -u -r1.19 -r1.18
--- debuggerjpda/ui/src/org/netbeans/modules/debugger/jpda/ui/models/WatchesNodeModel.java      20 Sep 2007 16:51:14
-0000      1.19
+++ debuggerjpda/ui/src/org/netbeans/modules/debugger/jpda/ui/models/WatchesNodeModel.java      18 Jun 2007 07:51:23
-0000      1.18
@@ -100,7 +100,7 @@
     }
     
     public boolean canRename(Object node) throws UnknownTypeException {
-        return false;//(node instanceof JPDAWatch);
+        return (node instanceof JPDAWatch);
     }
 
     public boolean canCopy(Object node) throws UnknownTypeException {
Comment 5 Stanislav Aubrecht 2007-10-18 15:23:58 UTC
unfortunatelly, this is not a simple fix. it'll have to wait for treetable rewrite
Comment 6 Stanislav Aubrecht 2008-06-18 16:18:03 UTC
new treetableview is now available and it does support in-place editing of cells in tree column, see #33281
please switch to OutlineView in debugger views to fix this issue


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo