Bug 31393 - Opened suboptions dialogs has not focus.
Opened suboptions dialogs has not focus.
Status: VERIFIED INVALID
Product: platform
Classification: Unclassified
Component: Window System
3.x
PC Linux
: P3 (vote)
: 3.x
Assigned To: mslama
issues@platform
: A11Y, FOCUS
: 18771 31395 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-24 11:50 UTC by ehucka
Modified: 2008-12-22 23:53 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ehucka 2003-02-24 11:50:26 UTC
Build dev 200302240100
Linux RH 7.2 GNome
JDK 1.4.1

It seems all modal dialogs opened from Options
window are not default focused.
For example:

try to open Options and than Editing->Editor
settings->Java Editor->Keybindings
Comment 1 mslama 2003-02-25 10:03:05 UTC
I will check focus.
Comment 2 ehucka 2003-02-25 10:36:00 UTC
With W2K it works right. I reproduced it on Linux only.
Comment 3 ehucka 2003-03-10 10:05:58 UTC
It seems the most of modal dialogs opened from some window or dialog
have not focus after their opening.
Internalization wizard -> Add, CC Database Manager -> Add, Update etc.

Could you do something with it?
Comment 4 Martin Roskanin 2003-03-10 10:13:09 UTC
*** Issue 18771 has been marked as a duplicate of this issue. ***
Comment 5 Marian Mirilovic 2003-03-10 11:08:14 UTC
*** Issue 31395 has been marked as a duplicate of this issue. ***
Comment 6 _ tboudreau 2004-02-20 14:28:12 UTC
The focus behavior of custom editor dialogs is heavily backed by unit tests, and works 
correctly.  However, some Linux window managers do not obey focusing instructions - 
Sawfish and certain configurations of Blackbox in particular do not handle this correctly. 

So, I believe you that the problem exists - it's just not in NetBeans, it's in your window 
manager.  Typically this happens with window managers which do not automatically focus 
child dialogs.
Comment 7 Marian Mirilovic 2005-07-12 09:41:39 UTC
closed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo