Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 252267 - OutOfMemoryError: Java heap space
OutOfMemoryError: Java heap space
Status: RESOLVED DUPLICATE of bug 249165
Product: web
Classification: Unclassified
Component: HTML Project
8.0
All All
: P3 (vote)
: 8.1
Assigned To: Tomas Mysik
issues@web
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-05-06 13:19 UTC by mitsikyanthony
Modified: 2015-05-07 05:40 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.41 KB, text/plain)
2015-05-06 13:19 UTC, mitsikyanthony
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mitsikyanthony 2015-05-06 13:19:10 UTC
Build: NetBeans IDE 8.0.2 (Build 201411181905)
VM: Java HotSpot(TM) Client VM, 24.45-b08, Java(TM) SE Runtime Environment, 1.7.0_45-b18
OS: Windows XP

User Comments:
mitsikyanthony: problem: more windows don't run

GUEST: when loding JavaScript libs list, I think it's because the libs are too big - after I updated it.

GUEST: updating javascript libraries.
it hangs when clicking the update button.
it hangs after downloading the 2.0 GB master.zip file from github cdnjs
and it hangs when loading the javascript library list.

GUEST: Netbeans seized to work when developing Cordova app on iOS for Android devices.

GUEST: I updated the javascript library in the HTML5 template wizzard




Stacktrace: 
java.lang.OutOfMemoryError: Java heap space
   at java.util.Arrays.copyOf(Arrays.java:0)
   at java.lang.AbstractStringBuilder.expandCapacity(AbstractStringBuilder.java:0)
   at java.lang.AbstractStringBuilder.ensureCapacityInternal(AbstractStringBuilder.java:0)
   at java.lang.AbstractStringBuilder.append(AbstractStringBuilder.java:0)
   at java.lang.StringBuilder.append(StringBuilder.java:0)
   at org.netbeans.modules.web.clientproject.libraries.CDNJSLibrariesProvider.getFiles(CDNJSLibrariesProvider.java:378)
Comment 1 mitsikyanthony 2015-05-06 13:19:12 UTC
Created attachment 153539 [details]
stacktrace
Comment 2 Tomas Mysik 2015-05-07 05:40:10 UTC
Solved in development version of NetBeans. Thanks.

*** This bug has been marked as a duplicate of bug 249165 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo