Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 249165 - OutOfMemoryError: GC overhead limit exceeded
OutOfMemoryError: GC overhead limit exceeded
Status: RESOLVED FIXED
Product: web
Classification: Unclassified
Component: HTML Project
8.0
All All
: P3 (vote)
: 8.1
Assigned To: Tomas Mysik
issues@web
EXCEPTIONS_REPORT
:
: 244420 250621 250658 250771 252267 253451 254187 254597 254828 254914 256559 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-12-06 06:04 UTC by dsuper7
Modified: 2015-11-13 06:37 UTC (History)
10 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.56 KB, text/plain)
2014-12-06 06:04 UTC, dsuper7
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dsuper7 2014-12-06 06:04:34 UTC
Build: NetBeans IDE 8.0.2 (Build 201411181905)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.11-b03, Java(TM) SE Runtime Environment, 1.8.0_11-b12
OS: Mac OS X

User Comments:
dsuper7: Had a giant awful project I just loaded and was rebuilding the javascript library when it brought this puppy to its kneeeeeees. 

Steps to reproduce: 
- Obtain disorganized project with thousands of files littered with syntax errors. 
- Download all of those files by adding the ftp server that hosts them as a remote host for a PHP Project in Netbeans 
- Allow netbeans to scan the entire project. *NOTE: I have phpmd phpcs installed as well. 
- Once the scanning is complete click the Javascript LIbrary rebuild link via the project properties dialouge. 

**Observe while struggling to gather all of the millions of javascript libraries it crashes and burns.




Stacktrace: 
java.lang.OutOfMemoryError: GC overhead limit exceeded
   at java.util.Arrays.copyOf(Arrays.java:3326)
   at java.lang.AbstractStringBuilder.expandCapacity(AbstractStringBuilder.java:137)
   at java.lang.AbstractStringBuilder.ensureCapacityInternal(AbstractStringBuilder.java:121)
   at java.lang.AbstractStringBuilder.append(AbstractStringBuilder.java:421)
   at java.lang.StringBuilder.append(StringBuilder.java:136)
   at org.netbeans.modules.web.clientproject.libraries.CDNJSLibrariesProvider.getLibraryRootURL(CDNJSLibrariesProvider.java:390)
Comment 1 dsuper7 2014-12-06 06:04:36 UTC
Created attachment 150932 [details]
stacktrace
Comment 2 Tomas Mysik 2015-02-11 13:50:50 UTC
Should be already fixed in dev version, NetBeans provides a new way to
add/update CDNJS libraries.

Thanks.
Comment 3 Tomas Hurka 2015-02-23 08:42:53 UTC
*** Bug 250621 has been marked as a duplicate of this bug. ***
Comment 4 Tomas Hurka 2015-02-24 15:29:02 UTC
*** Bug 250658 has been marked as a duplicate of this bug. ***
Comment 5 Tomas Hurka 2015-02-27 15:30:32 UTC
*** Bug 250771 has been marked as a duplicate of this bug. ***
Comment 6 Tomas Mysik 2015-05-07 05:40:11 UTC
*** Bug 252267 has been marked as a duplicate of this bug. ***
Comment 7 Tomas Mysik 2015-07-14 08:29:07 UTC
*** Bug 253451 has been marked as a duplicate of this bug. ***
Comment 8 Tomas Mysik 2015-07-28 13:35:23 UTC
*** Bug 244420 has been marked as a duplicate of this bug. ***
Comment 9 Tomas Mysik 2015-08-17 07:45:28 UTC
*** Bug 254187 has been marked as a duplicate of this bug. ***
Comment 10 Tomas Mysik 2015-08-24 05:22:03 UTC
*** Bug 254597 has been marked as a duplicate of this bug. ***
Comment 11 Tomas Mysik 2015-08-31 05:14:36 UTC
*** Bug 254828 has been marked as a duplicate of this bug. ***
Comment 12 Tomas Hurka 2015-09-10 15:45:38 UTC
*** Bug 254914 has been marked as a duplicate of this bug. ***
Comment 13 Tomas Mysik 2015-11-13 06:37:24 UTC
*** Bug 256559 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo