Bug 251825 - com.sun.tools.javac.jvm.ClassReader.fillIn: LowPerformance took 67461 ms.
com.sun.tools.javac.jvm.ClassReader.fillIn: LowPerformance took 67461 ms.
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Editor
8.1
All All
: P3 (vote)
: 8.1
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
: 252013 252592 255163 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-04-14 13:07 UTC by Jesse Glick
Modified: 2015-09-15 08:52 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (1.23 MB, application/nps)
2015-04-14 13:07 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2015-04-14 13:07:33 UTC
This issue was reported manually by jglick.
It already has 1 duplicates 


Build: NetBeans IDE Dev (Build 20150330-a97a99638a8e)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.25-b02, Java(TM) SE Runtime Environment, 1.8.0_25-b17
OS: Linux

User Comments:
jglick: Trying to run code completion on `is` (from Matchers in Hamcrest). IDE froze with disk spinning occasionally.



Maximum slowness yet reported was 67461 ms, average is 67461
Comment 1 Jesse Glick 2015-04-14 13:07:43 UTC
Created attachment 153189 [details]
nps snapshot
Comment 2 Jesse Glick 2015-04-14 13:12:56 UTC
BTW this was originally misfiled as #251449. I split it out of the duplicates list in the exception reporter.
Comment 3 Dusan Balek 2015-04-29 07:40:09 UTC
Fixed in jet-main.

http://hg.netbeans.org/jet-main/rev/e4fcbc337184
Comment 4 Quality Engineering 2015-04-30 02:33:19 UTC
Integrated into 'main-silver', will be available in build *201504300001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/e4fcbc337184
User: Dusan Balek <dbalek@netbeans.org>
Log: Issue #251825: com.sun.tools.javac.jvm.ClassReader.fillIn: LowPerformance - fixed.
Comment 5 Tomas Hurka 2015-05-14 14:51:21 UTC
*** Bug 252013 has been marked as a duplicate of this bug. ***
Comment 6 Dusan Balek 2015-08-07 15:19:45 UTC
*** Bug 252592 has been marked as a duplicate of this bug. ***
Comment 7 Dusan Balek 2015-09-15 08:52:46 UTC
*** Bug 255163 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo