Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 228120 - Breadcrumbs are missing in XML editor
Breadcrumbs are missing in XML editor
Status: RESOLVED FIXED
Product: xml
Classification: Unclassified
Component: Text-Edit
7.3
PC Windows 7
: P1 with 3 votes (vote)
: 8.1
Assigned To: Svata Dedic
issues@xml
:
: 217927 243147 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-31 17:36 UTC by markiewb
Modified: 2016-07-10 18:10 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Show difference between XML and HTML editor (68.33 KB, image/png)
2013-03-31 17:36 UTC, markiewb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description markiewb 2013-03-31 17:36:29 UTC
Created attachment 133241 [details]
Show difference between XML and HTML editor

ACTUAL: there are no breadcrumbs in XML editor (but in HTML editor) - see screenshot

EXPECTED: breadcrumbs in XML editor (AND in HTML editor)

Product Version: NetBeans IDE 7.3 (Build 201302132200)
Comment 1 Svata Dedic 2013-04-02 05:05:53 UTC
The breadcrumbs feature has no common infrastructure and so far was (by design) only implemented in Java and for CSL-based language supports (which is not the XML case).
Turning to an enhancement, increasing priority.
Comment 2 markiewb 2014-05-06 13:40:04 UTC
*** Bug 243147 has been marked as a duplicate of this bug. ***
Comment 3 Svata Dedic 2015-05-04 14:34:15 UTC
Implemented in jet-main#7df518bc4726
Comment 4 Quality Engineering 2015-05-12 03:26:43 UTC
Integrated into 'main-silver', will be available in build *201505120001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/aad62b7919a8
User: Svata Dedic <sdedic@netbeans.org>
Log: #228120, #251107: Implemented Breadcrumbs support and caret tracking in the navigator
Comment 5 markiewb 2016-07-10 18:10:36 UTC
*** Bug 217927 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo