Bug 222614 - 'Add from' Palette Manager buttons does not work as expected
'Add from' Palette Manager buttons does not work as expected
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Dialogs&Wizards
7.3
PC Windows XP
: P3 (vote)
: 7.3
Assigned To: Stanislav Aubrecht
issues@platform
:
: 222615 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-22 16:36 UTC by lehel
Modified: 2012-11-29 02:33 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
IDE log (263.13 KB, text/plain)
2012-11-22 16:36 UTC, lehel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lehel 2012-11-22 16:36:15 UTC
Product Version = NetBeans IDE Dev (Build 201211200002)
Operating System = Windows XP version 5.1 running on x86
Java; VM; Vendor = 1.7.0_10-ea
Runtime = Java HotSpot(TM) Client VM 23.6-b04

The Palette Manager offers 3 possibilities, adding a new component to the palette. These are: “Add from JAR”, “Add from Library”, “Add from Project”.
Their name are different but, in this version of Netbeans, these buttons/functions, clicking on them, offers the same window, no matter on which I was clicking.
Comment 1 lehel 2012-11-22 16:36:26 UTC
Created attachment 128272 [details]
IDE log
Comment 2 Michel Graciano 2012-11-22 16:58:44 UTC
Well, is is definitively broken, you should file a issue about that. I have tested that and my result was:
1. Opened the UI
2. Selected Add from JAR and the right dialog was opened and closed (using ESC);
3. Selected Add from Library and the was opened and I closed it (ESC);
4. After step 3, no matter what option I chose, just the Libraries UI is opened, even if I close the 'Palette Manager' UI;
Comment 3 Stanislav Aubrecht 2012-11-23 10:29:11 UTC
Import actions are define in form designer module, reassigning.
Comment 4 MackSix 2012-11-23 14:44:56 UTC
This is regression. It works in 7.2. It should be P1.
Comment 5 Tomas Pavek 2012-11-23 16:21:51 UTC
This was caused by fix of bug 220286. The WizardDescriptor instance when used for the second time to show a dialog is not properly updated after it was used for a wizard dialog that was canceled. See WizardDescriptor.updateStateOpen.
Comment 6 Tomas Pavek 2012-11-23 16:24:55 UTC
*** Bug 222615 has been marked as a duplicate of this bug. ***
Comment 7 lehel 2012-11-26 11:01:17 UTC
Also using here the "Add from jar button", a window to select a jar file is opening, but you can not click forward, on next/finish button...So everything is disabled even if you select a jar file, to add to the palette manager, therefore is no way to add something to your palette manager.
Comment 8 Stanislav Aubrecht 2012-11-27 14:49:12 UTC
core-main 6c788fbd2ccb
Comment 9 Quality Engineering 2012-11-29 02:33:41 UTC
Integrated into 'main-golden', will be available in build *201211290002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/6c788fbd2ccb
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #222614 - make sure WizardDescriptor instance is reusable even if cancelled


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo