Bug 220286 - NullPointerException at org.netbeans.modules.cnd.discovery.wizard.DiscoveryWizardIterator.current
NullPointerException at org.netbeans.modules.cnd.discovery.wizard.DiscoveryWi...
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Dialogs&Wizards
7.3
All All
: P3 (vote)
: 7.3
Assigned To: Stanislav Aubrecht
issues@platform
EXCEPTIONS_REPORT, discovery
:
: 229685 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 14:23 UTC by Alexander Simon
Modified: 2013-05-21 10:38 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.43 KB, text/plain)
2012-10-17 14:23 UTC, Alexander Simon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Simon 2012-10-17 14:23:49 UTC
Build: NetBeans IDE Dev (Build 20121017-4a2a9ffac449)
VM: Java HotSpot(TM) Client VM, 20.8-b03, Java(TM) SE Runtime Environment, 1.6.0_33-b03
OS: SunOS

Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.cnd.discovery.wizard.DiscoveryWizardIterator.current(DiscoveryWizardIterator.java:120)
   at org.openide.WizardDescriptor.updateStateOpen(WizardDescriptor.java:834)
   at org.openide.WizardDescriptor.updateState(WizardDescriptor.java:815)
   at org.openide.WizardDescriptor$6.run(WizardDescriptor.java:799)
   at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
   at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:646)
Comment 1 Alexander Simon 2012-10-17 14:23:51 UTC
Created attachment 126089 [details]
stacktrace
Comment 2 Alexander Simon 2012-10-26 13:41:14 UTC
Wizard's step implements WizardDescriptor.AsynchronousValidatingPanel.
When user click next button a long operation is performed out of EDT thread.
User can click finish button. Wizard iterator is uninitialized.
But after finishing of the long operation the WizardDescriptor accesses to uninitialized wizard iterator.
As result NPE.
Comment 3 Stanislav Aubrecht 2012-10-29 09:10:05 UTC
Looks like a duplicate of #202796

Next & Finish buttons are disabled during validation. However user changes in the wizard panel may re-enable Finish button during validation. If that is the case then this issue is duplicate of #202796.

Please provide exact steps to reproduce and reopen, thanks.
Comment 4 Alexander Simon 2012-10-29 09:20:22 UTC
(In reply to comment #3)
> Looks like a duplicate of #202796
> 
> Next & Finish buttons are disabled during validation. However user changes in
> the wizard panel may re-enable Finish button during validation. If that is the
> case then this issue is duplicate of #202796.
> 
> Please provide exact steps to reproduce and reopen, thanks.
Sorry I mixed up buttons, investigation should be:

Wizard's step implements WizardDescriptor.AsynchronousValidatingPanel.
When user click next button a long operation is performed out of EDT thread.
User can click cancel button. Wizard iterator is uninitialized.
But after finishing of the long operation the WizardDescriptor accesses to
uninitialized wizard iterator.
As result NPE.
Comment 5 Stanislav Aubrecht 2012-10-29 13:41:31 UTC
core-main f83890dd4647
Comment 6 Quality Engineering 2012-10-30 02:37:06 UTC
Integrated into 'main-golden', will be available in build *201210300001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/f83890dd4647
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #220286 - don't use wizard iterator if it was canceled during validation
Comment 7 Alexander Simon 2012-10-30 10:19:05 UTC
Not fixed.
Exception:
java.lang.NullPointerException
	at org.netbeans.modules.cnd.discovery.wizard.DiscoveryWizardIterator.nextPanel(DiscoveryWizardIterator.java:148)
	at org.openide.WizardDescriptor$Listener$1.run(WizardDescriptor.java:2114)
	at org.openide.WizardDescriptor$11$1.run(WizardDescriptor.java:1459)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:646)
	at java.awt.EventQueue.access$000(EventQueue.java:84)
	at java.awt.EventQueue$1.run(EventQueue.java:607)
	at java.awt.EventQueue$1.run(EventQueue.java:605)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:616)
	at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:158)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
[catch] at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
Comment 8 Stanislav Aubrecht 2012-11-02 09:02:04 UTC
core-main 6606466c21fe
Comment 9 Quality Engineering 2012-11-04 02:50:12 UTC
Integrated into 'main-golden', will be available in build *201211040001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/6606466c21fe
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #220286 - don't use wizard iterator if it was canceled during validation
Comment 10 Quality Engineering 2012-11-08 02:55:02 UTC
Integrated into 'main-golden', will be available in build *201211080001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/f735ab72147e
User: Alexander Simon <alexvsimon@netbeans.org>
Log: Bug #220286 NullPointerException at org.netbeans.modules.cnd.discovery.wizard.DiscoveryWizardIterator.current
- additional fix on cnd side
Comment 11 Alexander Simon 2013-05-21 10:38:33 UTC
*** Bug 229685 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo