Bug 222615 - IllegalArgumentException at org.netbeans.modules.nbform.palette.ChooseBeansWizardPanel.getComponent
IllegalArgumentException at org.netbeans.modules.nbform.palette.ChooseBeansWi...
Status: RESOLVED DUPLICATE of bug 222614
Product: guibuilder
Classification: Unclassified
Component: Code
7.3
All All
: P3 (vote)
: TBD
Assigned To: issues@guibuilder
issues@guibuilder
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-22 16:56 UTC by MackSix
Modified: 2012-11-23 16:24 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (7.00 KB, text/plain)
2012-11-22 16:56 UTC, MackSix
Details

Note You need to log in before you can comment on or make changes to this bug.
Description MackSix 2012-11-22 16:56:31 UTC
Build: NetBeans IDE Dev (Build 201211200002)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.6-b04, Java(TM) SE Runtime Environment, 1.7.0_10-ea-b16
OS: Windows 7

User Comments:
MackSix: 1. Tools>>Palette>>Swing/Awt Components...
2. Click "Add From Jar..."
3. In "Files of type:" field, choose "All Files"
4. Choose a file so that the "Next" button is activated.
5. Click "Cancel"
6. Click "Add From Project..."
7. Choose a Java file and click "Next" button.

This Exception Occurs.




Stacktrace: 
java.lang.IllegalArgumentException
   at org.netbeans.modules.nbform.palette.ChooseBeansWizardPanel.getComponent(ChooseBeansWizardPanel.java:99)
   at org.openide.WizardDescriptor$Listener.actionPerformed(WizardDescriptor.java:2107)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(NativeMethodAccessorImpl.java:0)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
   at java.lang.reflect.Method.invoke(Method.java:601)
Comment 1 MackSix 2012-11-22 16:56:33 UTC
Created attachment 128275 [details]
stacktrace
Comment 2 MackSix 2012-11-22 17:00:42 UTC
Related to this bug: http://netbeans.org/bugzilla/show_bug.cgi?id=222614
Comment 3 Tomas Pavek 2012-11-23 16:24:55 UTC
Much likely a consequence of bug 222614.

*** This bug has been marked as a duplicate of bug 222614 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo