Bug 206246 - [71cat] IAE: Attempt to remove nonexistent path ... from maven.ProjectOpenedHookImpl.projectClosed
[71cat] IAE: Attempt to remove nonexistent path ... from maven.ProjectOpenedH...
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Maven
7.1
All All
: P4 (vote)
: Dev
Assigned To: Milos Kleint
issues@projects
EXCEPTIONS_REPORT
: ERGONOMICS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-12 02:26 UTC by brettryan
Modified: 2014-04-14 09:03 UTC (History)
9 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.60 KB, text/plain)
2011-12-12 02:26 UTC, brettryan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description brettryan 2011-12-12 02:26:55 UTC
This bug was originally marked as duplicate of bug 201617, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 201112110600)
VM: Java HotSpot(TM) 64-Bit Server VM, 21.0-b17, Java(TM) SE Runtime Environment, 1.7.0-b147
OS: Windows 7

User Comments:
brettryan: Trying to remove project group.

jkovalsky: I had ReproduceNB Maven projects [1] opened and compiled. On the parent project called "Close Dependent Projects" and then "Close Project" on the remaining parent project generated this exception.

[1] http://netbeans.org/bugzilla/attachment.cgi?id=111943

mhmdchebbi: happen when closing a maven project

GUEST: Closing a project

jportway: closing enterprise app maven project

carcassi: Changed active group

GUEST: Creating a project group from my currently opened projects.  All projects are Maven projects.

sunbiz: Closing multiple projects throws this exception

RageSteel: I selected 7 project than right click on then and select 
Comment 1 brettryan 2011-12-12 02:26:59 UTC
Created attachment 114035 [details]
stacktrace
Comment 2 Jesse Glick 2011-12-12 20:32:50 UTC
Most reports are probably duplicates of bug #201617. Report #550435 is something else, I think due to unbalanced project open/close hooks from ergonomics. Cf. bug #203220 comment #9.
Comment 3 Milos Kleint 2012-04-05 06:02:59 UTC
maybe a duplicate of issue 209815 ?
Comment 4 Jesse Glick 2012-04-05 14:29:05 UTC
I do not think this is a duplicate; bug #209815 was a problem in project lookup whereas this seems related to ergonomics.
Comment 5 Milos Kleint 2014-04-14 09:03:49 UTC
no more reports in post 7.2 builds, closing


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo