Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 202229 - [71cat] AssertionError: Should be a folder: C:\nb\main\nbbuild\netbeans\harness\modules@dfe71616:9f8f43
[71cat] AssertionError: Should be a folder: C:\nb\main\nbbuild\netbeans\harne...
Status: RESOLVED DUPLICATE of bug 202413
Product: platform
Classification: Unclassified
Component: Filesystems
7.0
All All
: P3 (vote)
: 7.1
Assigned To: Jaroslav Tulach
issues@platform
EXCEPTIONS_REPORT
: REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-16 13:49 UTC by Peter Nabbefeld
Modified: 2011-10-12 08:33 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (891 bytes, text/plain)
2011-09-16 13:49 UTC, Peter Nabbefeld
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Nabbefeld 2011-09-16 13:49:16 UTC
This bug was originally marked as duplicate of bug 200512, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build nbms-and-javadoc-7840-on-20110906)
VM: Java HotSpot(TM) Client VM, 21.0-b17, Java(TM) SE Runtime Environment, 1.7.0-b147
OS: Windows XP

User Comments:
epdv: Tried to Clean and Build NetBeans from source




Stacktrace: 
java.lang.AssertionError: Should be a folder: C:\nb\main\nbbuild\netbeans\harness\modules@dfe71616:9f8f43
   at org.netbeans.modules.masterfs.watcher.Watcher$Ext.unregister(Watcher.java:247)
   at org.netbeans.modules.masterfs.watcher.Watcher.unregister(Watcher.java:130)
   at org.netbeans.modules.masterfs.filebasedfs.fileobjects.BaseFileObj.removeFileChangeListener(BaseFileObj.java:508)
   at sun.reflect.GeneratedMethodAccessor104.invoke(GeneratedMethodAccessor104.java:0)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
   at java.lang.reflect.Method.invoke(Method.java:601)
Comment 1 Peter Nabbefeld 2011-09-16 13:49:20 UTC
Created attachment 110813 [details]
stacktrace
Comment 2 Peter Nabbefeld 2011-09-16 14:01:58 UTC
I've not seen this bug earlier, seems to be relatively new. See also bug #200512. However, I've not created the folder again as a file. Seems to be wrong error message for non-existing file. Probably some module tries to access a file, while NB did not notice that it's deleted.

The folder has been deleted by Ant, so I'd guess it's deleted externally (from NBs point of view): The FileObject and DataObject still may exist, while it's already gone. However, NB should notice it does no more exist instead of saying, it's not a folder any more - probably there's a test like "object.isFolder()" which returns false, because the folder doesn't exist.

I've never seen sth. like this for files, so there's probably some other method used to detect what's going on - or the folder's listener has been changed to not fire the corresponding events correctly.
Comment 3 Jaroslav Tulach 2011-10-12 08:33:16 UTC

*** This bug has been marked as a duplicate of bug 202413 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo