Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 202413 - [71cat] AssertionError: Should be a folder: D:\Test\WebRequestOld\build\web\WEB-INF@1297c48f:1aa59d2
[71cat] AssertionError: Should be a folder: D:\Test\WebRequestOld\build\web\W...
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Filesystems
7.0
All All
: P3 (vote)
: 7.1
Assigned To: Jaroslav Tulach
issues@platform
EXCEPTIONS_REPORT
:
: 201465 202109 202229 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-21 11:59 UTC by muellermi
Modified: 2011-10-15 14:46 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.19 KB, text/plain)
2011-09-21 11:59 UTC, muellermi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description muellermi 2011-09-21 11:59:06 UTC
Build: NetBeans IDE Dev (Build 201109180600)
VM: Java HotSpot(TM) Client VM, 21.0-b17, Java(TM) SE Runtime Environment, 1.7.0-b147
OS: Windows XP

Stacktrace: 
java.lang.AssertionError: Should be a folder: D:\Test\WebRequestOld\build\web\WEB-INF@1297c48f:1aa59d2
   at org.netbeans.modules.masterfs.watcher.Watcher$Ext.register(Watcher.java:224)
   at org.netbeans.modules.masterfs.watcher.Watcher.register(Watcher.java:119)
   at org.netbeans.modules.masterfs.filebasedfs.fileobjects.BaseFileObj.addFileChangeListener(BaseFileObj.java:501)
   at org.openide.filesystems.FileUtil$Holder.locateCurrent(FileUtil.java:436)
   at org.openide.filesystems.FileUtil$Holder.someChange(FileUtil.java:454)
   at org.openide.filesystems.FileUtil$Holder.fileDataCreated(FileUtil.java:507)
Comment 1 muellermi 2011-09-21 11:59:10 UTC
Created attachment 110961 [details]
stacktrace
Comment 2 Jaroslav Tulach 2011-10-12 08:31:53 UTC
Changeset: 16b4db5e1eb9
Author:    Jaroslav Tulach <jtulach@netbeans.org>
Date:      2011-10-12 10:05
Message:   More info in the assert
Issue #202413 - [71cat] AssertionError: Should be a folder: D:\Test\WebRequestOld\build\web\WEB-INF@1297c48f:1aa59d2
Comment 3 Jaroslav Tulach 2011-10-12 08:33:16 UTC
*** Bug 202229 has been marked as a duplicate of this bug. ***
Comment 4 Jaroslav Tulach 2011-10-12 08:33:38 UTC
*** Bug 201465 has been marked as a duplicate of this bug. ***
Comment 5 Jaroslav Tulach 2011-10-12 08:33:45 UTC
*** Bug 202109 has been marked as a duplicate of this bug. ***
Comment 6 Quality Engineering 2011-10-15 14:46:26 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/16b4db5e1eb9
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: More info in the assert
Issue #202413 - [71cat] AssertionError: Should be a folder: D:\Test\WebRequestOld\build\web\WEB-INF@1297c48f:1aa59d2


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo