Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 200512 - [70cat] AssertionError: Should be a folder: D:\projects\WebRequest\web\resources\script\projects\WebRequest\web\resources\script@73a1dde7:103096b
[70cat] AssertionError: Should be a folder: D:\projects\WebRequest\web\resour...
Status: RESOLVED WORKSFORME
Product: platform
Classification: Unclassified
Component: Filesystems
7.0
All All
: P4 (vote)
: 7.1
Assigned To: Jaroslav Tulach
issues@platform
EXCEPTIONS_REPORT
:
: 206880 206929 207205 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-29 12:05 UTC by muellermi
Modified: 2012-01-12 18:39 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (933 bytes, text/plain)
2011-07-29 12:05 UTC, muellermi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description muellermi 2011-07-29 12:05:17 UTC
Build: NetBeans IDE Dev (Build 201107280600)
VM: Java HotSpot(TM) Client VM, 21.0-b17, Java(TM) SE Runtime Environment, 1.7.0-b147
OS: Windows XP

User Comments:
muellermi: opening script file




Stacktrace: 
java.lang.AssertionError: Should be a folder: D:\projects\WebRequest\web\resources\script\projects\WebRequest\web\resources\script@73a1dde7:103096b
   at org.netbeans.modules.masterfs.watcher.Watcher$Ext.unregister(Watcher.java:247)
   at org.netbeans.modules.masterfs.watcher.Watcher.unregister(Watcher.java:130)
   at org.netbeans.modules.masterfs.filebasedfs.fileobjects.BaseFileObj.removeFileChangeListener(BaseFileObj.java:487)
   at sun.reflect.GeneratedMethodAccessor264.invoke(GeneratedMethodAccessor264.java:0)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
   at java.lang.reflect.Method.invoke(Method.java:601)
Comment 1 muellermi 2011-07-29 12:05:21 UTC
Created attachment 109695 [details]
stacktrace
Comment 2 Jaroslav Tulach 2011-07-29 12:38:39 UTC
I guess I know how this problem may appear. For example: a folder is created which is then removed and turned into a file. On cleanup after GC this assert could fail.

I don't think this needs any fix. It is only assert, otherwise harmless. Unless there are more reports of this kind, I leave it worksforme.
Comment 3 Jaroslav Tulach 2012-01-04 20:41:02 UTC
*** Bug 206880 has been marked as a duplicate of this bug. ***
Comment 4 Jaroslav Tulach 2012-01-05 06:14:40 UTC
*** Bug 206929 has been marked as a duplicate of this bug. ***
Comment 5 Jaroslav Tulach 2012-01-12 18:39:21 UTC
*** Bug 207205 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo