Bug 196753 - 87s - editor.BaseKit$InsertBreakAction.actionPerformed()
87s - editor.BaseKit$InsertBreakAction.actionPerformed()
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Formatting & Indentation
6.x
All All
: P3 (vote)
: 7.0.1
Assigned To: Dusan Balek
issues@editor
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
: 197183 199878 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-16 08:21 UTC by Exceptions Reporter
Modified: 2011-09-13 15:29 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (81.16 KB, application/nps)
2011-03-16 08:21 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2011-03-16 08:21:16 UTC
Build: NetBeans IDE 6.9.1 (Build 201011082200)
VM: Java HotSpot(TM) Client VM, 19.1-b02, Java(TM) SE Runtime Environment, 1.6.0_24-b07
OS: Windows Vista

User Comments:
GUEST: Opening a PHP project (Scanning projects) with remote (LAN) sources



Maximum slowness yet reported was 86730 ms, average is 31520
Comment 1 Exceptions Reporter 2011-03-16 08:21:30 UTC
Created attachment 107034 [details]
nps snapshot
Comment 2 Jaroslav Tulach 2011-03-16 11:53:43 UTC
The AWT thread is blocked in
org.netbeans.editor.BaseKit$InsertBreakAction.actionPerformed()

Also note there are five "Editor Braces Matching" threads! That is probably too much and they should use single throughput RequestProcessor...
Comment 3 Dusan Balek 2011-03-17 09:31:05 UTC
The AWT thread is blocked in
org.netbeans.editor.BaseKit$InsertBreakAction.actionPerformed() waiting to acquire the indent lock that was shared with the reformat lock already held by slow Html reformat action. A possible solution is to split the indent lock from the reformat lock.

Fixed in jet-main.

http://hg.netbeans.org/jet-main/rev/a310040284de
Comment 4 Dusan Balek 2011-03-17 10:02:08 UTC
OOPS - one more change
http://hg.netbeans.org/jet-main/rev/177886c7c5c5
Comment 5 Quality Engineering 2011-03-18 09:45:56 UTC
Integrated into 'main-golden', will be available in build *201103180400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/a310040284de
User: Dusan Balek <dbalek@netbeans.org>
Log: Issue #196753: 87s - editor.BaseKit$InsertBreakAction.actionPerformed() - fixed.
Comment 6 Dusan Balek 2011-04-05 09:12:42 UTC
*** Bug 197183 has been marked as a duplicate of this bug. ***
Comment 7 Dusan Balek 2011-09-13 15:29:57 UTC
*** Bug 199878 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo