Bug 199878 - 140s - waiting for indentation lock
140s - waiting for indentation lock
Status: RESOLVED DUPLICATE of bug 196753
Product: java
Classification: Unclassified
Component: Source
7.0
All All
: P2 (vote)
: 7.0.1
Assigned To: Dusan Balek
issues@platform
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-04 13:50 UTC by majiknet
Modified: 2011-09-13 15:29 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (1.09 MB, application/nps)
2011-07-04 13:50 UTC, majiknet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description majiknet 2011-07-04 13:50:15 UTC
Build: NetBeans IDE 7.0 (Build 201104080000)
VM: Oracle JRockit(R), R28.1.3-11-141760-1.6.0_24-20110301-1429-windows-ia32, Java(TM) SE Runtime Environment, 1.6.0_24-b07
OS: Windows 7

User Comments:
tnleeuw: Switching between a JS and JSP file in editor



Maximum slowness yet reported was 140280 ms, average is 39583
Comment 1 majiknet 2011-07-04 13:50:45 UTC
Created attachment 109225 [details]
nps snapshot
Comment 2 Jaroslav Tulach 2011-07-14 09:46:17 UTC
In AWT: org.netbeans.modules.web.core.syntax.gsf.JspKeystrokeHandler$1.run() waits for org.netbeans.modules.editor.indent.IndentImpl.indentLock()
That one waits for org.netbeans.modules.parsing.impl.Utilities.acquireParserLock()
Comment 3 Dusan Balek 2011-09-13 15:29:57 UTC
Already fixed.

*** This bug has been marked as a duplicate of bug 196753 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo