Bug 194733 - IllegalArgumentException: committed = 530382848 should be < max = 530186240
IllegalArgumentException: committed = 530382848 should be < max = 530186240
Status: RESOLVED WORKSFORME
Product: platform
Classification: Unclassified
Component: JDK Problems
6.x
All All
: P3 (vote)
: 7.4
Assigned To: Stanislav Aubrecht
issues@platform
EXCEPTIONS_REPORT 721-reviewed
:
: 194858 215253 215254 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-26 13:34 UTC by adben
Modified: 2013-07-31 14:03 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.01 KB, text/plain)
2011-01-26 13:34 UTC, adben
Details

Note You need to log in before you can comment on or make changes to this bug.
Description adben 2011-01-26 13:34:24 UTC
Build: NetBeans IDE Dev (Build 201101250001)
VM: Java HotSpot(TM) 64-Bit Server VM, 17.1-b03-307, Java(TM) SE Runtime Environment, 1.6.0_22-b04-307-10M3261
OS: Mac OS X

User Comments:
adben: scanning a huge project (Liferay portal 6.0.5) source code




Stacktrace: 
java.lang.IllegalArgumentException: committed = 530382848 should be < max = 530186240
   at java.lang.management.MemoryUsage.<init>(MemoryUsage.java:145)
   at sun.management.MemoryImpl.getMemoryUsage0(MemoryImpl.java:0)
   at sun.management.MemoryImpl.getHeapMemoryUsage(MemoryImpl.java:61)
   at org.netbeans.modules.parsing.lucene.support.LowMemoryWatcher.isLowMemory(LowMemoryWatcher.java:73)
   at org.netbeans.modules.java.source.indexing.MultiPassCompileWorker.compile(MultiPassCompileWorker.java:131)
   at org.netbeans.modules.java.source.indexing.JavaCustomIndexer$1.run(JavaCustomIndexer.java:201)
Comment 1 adben 2011-01-26 13:34:28 UTC
Created attachment 105366 [details]
stacktrace
Comment 2 adben 2011-01-29 23:03:36 UTC
in my netbeans.conf netbeans_default_options="-J-Xverify:none -J-Dcom.sun.mysql.startcommand=/usr/local/mysql/support-files/mysql-admin.server -J-Dcom.sun.mysql.stopcommand=/usr/local/mysql/support-files/mysql-admin.server -J-Dcom.sun.mysql.startargs=start -J-Dcom.sun.mysql.stopargs=stop -J-Dcom.sun.mysql.port=3306 -J-client  -J-Xss32m -J-Xms32m -J-Xmx512m -J-XX:PermSize=32m -J-XX:MaxPermSize=512m -J-Dnetbeans.logger.console=true -J-ea -J-Dapple.laf.useScreenMenuBar=true -J-Dapple.awt.graphics.UseQuartz=true -J-Dsun.java2d.noddraw=true -J-XX:+UseConcMarkSweepGC -J-XX:+CMSClassUnloadingEnabled -J-XX:+CMSPermGenSweepingEnabled -J-XX:+UseAdaptiveSizePolicy -J-XX:+PrintGCDetails -J-Dswing.aatext=true -J-Dawt.nativeDoubleBuffering=true -J-Dsun.java2d.d3d=false -J-Djava.net.preferIPv4Stack=true -J-Dsun.java2d.opengl=true"
Comment 3 Marian Mirilovic 2011-01-31 12:33:32 UTC
*** Bug 194858 has been marked as a duplicate of this bug. ***
Comment 4 Jan Lahoda 2011-09-17 19:54:30 UTC
No new reports for a quite some time, probably some transient problem in JDK.
Comment 5 Marian Mirilovic 2012-07-11 07:05:12 UTC
*** Bug 215253 has been marked as a duplicate of this bug. ***
Comment 6 Marian Mirilovic 2012-07-11 07:05:53 UTC
new report from 7.1.2 http://statistics.netbeans.org/exceptions/detail.do?id=190523
Comment 7 Marian Mirilovic 2012-07-11 07:06:48 UTC
... and http://statistics.netbeans.org/exceptions/detail.do?id=190524
Comment 8 Marian Mirilovic 2012-07-11 07:07:12 UTC
*** Bug 215254 has been marked as a duplicate of this bug. ***
Comment 9 Marian Mirilovic 2012-10-17 13:34:12 UTC
12 dups, some of them reported against 7.1.2 (<1year old), leaving opened ... but if you knows about any steps to reproduce, we would highly appreciate if you will share it with us. Thanks in advance.
Comment 10 Jan Lahoda 2013-02-26 17:19:10 UTC
To the best of my knowledge, this is a JDK bug.
Comment 11 Stanislav Aubrecht 2013-07-31 14:03:35 UTC
Please reopen if reproducible with JDK 1.7, thanks.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo