Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 215254 - IllegalArgumentException: committed = 2143879168 should be < max = 2143158272
IllegalArgumentException: committed = 2143879168 should be < max = 2143158272
Status: RESOLVED DUPLICATE of bug 194733
Product: ide
Classification: Unclassified
Component: Code
7.1
All All
: P3 (vote)
: 7.3
Assigned To: issues@ide
issues@ide
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-08 19:26 UTC by Exceptions Reporter
Modified: 2012-07-11 07:07 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.89 KB, text/plain)
2012-07-08 19:26 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2012-07-08 19:26:37 UTC
This bug was originally marked as duplicate of bug 194733, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.1.2 (Build 201204101705)
VM: Java HotSpot(TM) 64-Bit Server VM, 20.8-b03-424, Java(TM) SE Runtime Environment, 1.6.0_33-b03-424-11M3720
OS: Mac OS X

Stacktrace: 
java.lang.IllegalArgumentException: committed = 2143879168 should be < max = 2143158272
   at java.lang.management.MemoryUsage.<init>(MemoryUsage.java:145)
   at sun.management.MemoryImpl.getMemoryUsage0(MemoryImpl.java:0)
   at sun.management.MemoryImpl.getHeapMemoryUsage(MemoryImpl.java:61)
   at org.netbeans.modules.parsing.lucene.support.LowMemoryWatcher.isLowMemory(LowMemoryWatcher.java:73)
   at org.netbeans.modules.parsing.lucene.LuceneIndex._store(LuceneIndex.java:326)
   at org.netbeans.modules.parsing.lucene.LuceneIndex.access$200(LuceneIndex.java:98)
Comment 1 Exceptions Reporter 2012-07-08 19:26:41 UTC
Created attachment 121807 [details]
stacktrace
Comment 2 Marian Mirilovic 2012-07-11 07:07:12 UTC

*** This bug has been marked as a duplicate of bug 194733 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo