Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 18370 - OpenVMS launcher needs changes for 3.3
OpenVMS launcher needs changes for 3.3
Status: CLOSED DUPLICATE of bug 18368
Product: platform
Classification: Unclassified
Component: -- Other --
3.x
Other OpenVMS
: P1 (vote)
: 3.x
Assigned To: _ ttran
issues@platform
:
Depends on:
Blocks: 18368
  Show dependency treegraph
 
Reported: 2001-12-05 16:30 UTC by mgarrison
Modified: 2009-11-07 13:34 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Patch file for changes against release330 (15.55 KB, patch)
2001-12-05 19:33 UTC, mgarrison
Details | Diff
NetBeans 3.3 laucnher for OpenVMS (40.62 KB, text/plain)
2001-12-06 18:23 UTC, mgarrison
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mgarrison 2001-12-05 16:30:32 UTC
We have been testing some new support on OpenVMS for special characters in 
filenames.  Things seem to be working well!  This support for special 
characters in a filename on VMS is enabled using logical names in the 
launcher.  We also no longer set the properties for the attribute filename and 
the backup extension.  These changes also require changes in some other code, 
which are detailed in issue #18368.

In addition, this version of the launcher points at the proper JVM for this 
version of NetBeans and also implements a -help switch.

I'll attach the patch here for your review/approval unless you tell me to check 
it in (I'll need help getting the right branch I'm sure).

Meg
Comment 1 _ ttran 2001-12-05 17:01:36 UTC
Okay, go attach the patch, ASAP.  Time is running.  Thanks
Comment 2 mgarrison 2001-12-05 19:33:18 UTC
Created attachment 3702 [details]
Patch file for changes against release330
Comment 3 mgarrison 2001-12-05 19:37:08 UTC
These changes are required by Issue 18368.  And this change requires 
that the patch for 18368 also be applied.  If 18368 is rejected for 
release330, then this patch must be rejected for release330 as well.

We apologize for being so late with this.  We only recently received 
from our RTL group the changed libraries that support extended 
filenames.

Thanks,
Meg
Comment 4 _ ttran 2001-12-06 13:07:21 UTC
Meg, I had some difficulties with your patch.  It was created against
an older revision of runideopenvms.com (r1.4).  I had to manually fix it.
Next time please produce patches according to instructions from

   http://www.netbeans.org/contrib-patches.html

This (fixed) patch and the one from bug 18368 were merged together and
attached to 18368.  I mark this one as duplicate of #18368.

*** This issue has been marked as a duplicate of 18368 ***
Comment 5 mgarrison 2001-12-06 14:59:33 UTC
Hi Trung,

Thanks for adding the patch.  I'm confused about the revision 
problem, and I'd like to know what I did wrong.

I did the following:

cvs co -rrelease330 core/release/bin/runideopenvms.com

Then I made my changes and did a:

cvs -rrelease330 diff > runideopenvms.patch
cvs server: Diffing .

And the runideopenvms.patch file is what I provided to you.

Can you please point out what I did wrong so I don't make this 
mistake again?

Thanks!
Meg

Comment 6 mgarrison 2001-12-06 18:23:51 UTC
Created attachment 3720 [details]
NetBeans 3.3 laucnher for OpenVMS
Comment 7 mgarrison 2001-12-06 18:39:19 UTC
Hi Trung,

I just looked at the patch file I attached, and it was completely 
messed up.  I don't know how I managed to mess this up so badly, but 
I can't apologize enough.

I am attaching here the actual file I would like checked in.  I doubt 
I'll be able to mess this up (I probably shouldn't say that ;-))

Sooooo, if you could please check this file into the CVS library to 
go with issue 18368 I would be most appreciative.

Thanks,
Meg
Comment 8 _ ttran 2001-12-07 19:04:24 UTC
your patch has been committed in release330 branch.  Thanks
Comment 9 Quality Engineering 2003-07-01 15:49:00 UTC
Resolved for 3.4.x or earlier, no new info since then -> verified.

Comment 10 Quality Engineering 2003-07-01 16:37:06 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo