Bug 174849 - [68cat] Debugger in an unknown State
[68cat] Debugger in an unknown State
Status: VERIFIED FIXED
Product: debugger
Classification: Unclassified
Component: Code
6.x
PC Windows XP
: P1 (vote)
: 6.x
Assigned To: Martin Entlicher
issues@debugger
:
: 174869 174983 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-19 08:42 UTC by stefan79
Modified: 2009-10-22 23:36 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
The Logfile (37.08 KB, text/plain)
2009-10-19 08:42 UTC, stefan79
Details
A Hardcopy of the Windows (90.90 KB, image/jpeg)
2009-10-19 08:43 UTC, stefan79
Details
NPS File in this state. (144.38 KB, application/octet-stream)
2009-10-19 08:44 UTC, stefan79
Details

Note You need to log in before you can comment on or make changes to this bug.
Description stefan79 2009-10-19 08:42:22 UTC
[ BUILD # : 200910170201 ]
[ JDK VERSION : 1.6.* ]

I started a Debug-Session and debugged Step-by-Step some
Java-Classes.
After pressing F7, the debugger stopped and only the Stop-Button is
enabled.

There´s one Exception in the Log-file:
INFO [org.netbeans.spi.editor.highlighting.support.OffsetsBag]: Too
high endIdx=1, marks.size()=1, startIdx=0, startOffset=4504,
endOffset=4519, changeStart=4504, document.getLength()=5220,
lastMark=offset=4504,
attribs=org.netbeans.api.editor.settings.AttributesUtilities$Immutable
@16e3d49
java.lang.Exception
        at
org.netbeans.spi.editor.highlighting.support.OffsetsBag.removeHighligh
ts(OffsetsBag.java:405)
        at
org.netbeans.modules.debugger.jpda.projects.DebuggerAnnotation$Highlig
htAnnotatable.removeAnnotation(DebuggerAnnotation.java:169)
        at org.openide.text.Annotation.detach(Annotation.java:133)
        at
org.netbeans.modules.debugger.jpda.projects.EditorContextImpl.removeAn
notation(EditorContextImpl.java:352)
        at
org.netbeans.modules.debugger.jpda.projects.EditorContextImpl.removeAn
notation(EditorContextImpl.java:344)
[catch] at
org.netbeans.modules.debugger.jpda.ui.CurrentThreadAnnotationListener$
RemoveAnnotationsTask.run(CurrentThreadAnnotationListener.java:374)
        at
org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:602)
        at
org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:
1084)
Comment 1 stefan79 2009-10-19 08:42:55 UTC
Created attachment 89672 [details]
The Logfile
Comment 2 stefan79 2009-10-19 08:43:38 UTC
Created attachment 89673 [details]
A Hardcopy of the Windows
Comment 3 stefan79 2009-10-19 08:44:59 UTC
Created attachment 89674 [details]
NPS File in this state.
Comment 4 stefan79 2009-10-19 13:52:35 UTC
I changed the priority, because today I started 7 Debug-Sessions and only 2 Sessions worked correct.
Comment 5 Vojtech Sigler 2009-10-19 14:00:25 UTC
I experienced two similar issues, but I am not sure if they are the same as this, so I filed them separately:

http://www.netbeans.org/issues/show_bug.cgi?id=174863
http://www.netbeans.org/issues/show_bug.cgi?id=174869
Comment 6 Martin Entlicher 2009-10-19 14:04:49 UTC
The exception at OffsetsBag.removeHighlights is already submitted as issue #173662.

I can reproduce this strange state, it seems to be caused by bad pairing of ReentrantReadWriteLocks.
Comment 7 Vojtech Sigler 2009-10-19 14:34:21 UTC
I see this as a stopper for beta.
Comment 8 Martin Entlicher 2009-10-20 07:45:52 UTC
I had the fix yesterday, but could not integrate it due to Mercurial issues.
Now it's fixed in changeset:   150009:18279e58b2a2
http://hg.netbeans.org/main/rev/18279e58b2a2
Comment 9 Marian Mirilovic 2009-10-20 08:13:23 UTC
Martin Thanks, Vojta please verify in trunk before we'll integrate into beta clone ... it means we will have a new build
tomorrow - for sure.
Comment 10 Martin Entlicher 2009-10-20 08:25:05 UTC
*** Issue 174869 has been marked as a duplicate of this issue. ***
Comment 11 Vojtech Sigler 2009-10-20 13:36:16 UTC
Verified in trunk build 20091020112920. Will mark as verified once it is integrated into beta.
Comment 12 Martin Entlicher 2009-10-20 13:52:47 UTC
Thanks. I'm in process of cloning release68_beta, but the first attempt failed with "unknown exception encountered"
error after 2.5 hours.

Mercurial malfunction really delays things a lot.
Comment 13 Jan Pokorsky 2009-10-20 15:07:58 UTC
*** Issue 174983 has been marked as a duplicate of this issue. ***
Comment 14 Martin Entlicher 2009-10-20 17:23:41 UTC
After 4 hours I have a successful clon of release68_beta. I'll transplant the fix later today...
Comment 15 Martin Entlicher 2009-10-20 19:13:21 UTC
Transplant of the trivial change in 1 file took 8 minutes. I really do not get why Mercurial must do such tremendous
amount of work for trivial tasks.

Pushed as changeset:   149857:aba2985f3202
http://hg.netbeans.org/release68_beta/rev/aba2985f3202
Comment 16 Vojtech Sigler 2009-10-21 10:07:37 UTC
Verified in NetBeans IDE 6.8 Beta (Build 200910202101)
Comment 17 Quality Engineering 2009-10-22 23:36:02 UTC
Integrated into 'main-golden', will be available in build *200910221401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/18279e58b2a2
User: mentlicher@netbeans.org
Log: #174849 - Assure that the thread access lock gets unlocked. Fix of issue #174710 is changed.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo