Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 174983 - deadlock on step over
deadlock on step over
Status: CLOSED DUPLICATE of bug 174849
Product: debugger
Classification: Unclassified
Component: Java
6.x
PC Linux
: P2 (vote)
: 6.x
Assigned To: issues@debugger
issues@debugger
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-20 11:50 UTC by Jan Pokorsky
Modified: 2010-05-06 08:02 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
thread dump (32.34 KB, text/plain)
2009-10-20 11:52 UTC, Jan Pokorsky
Details
another thread dump (30.92 KB, text/plain)
2009-10-20 11:52 UTC, Jan Pokorsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Pokorsky 2009-10-20 11:50:42 UTC
Product Version: NetBeans IDE Dev (Build 091019)
Java: 1.6.0_16; Java HotSpot(TM) 64-Bit Server VM 14.2-b01
System: Linux version 2.6.28-15-generic running on amd64; UTF-8; en_US (nb)

I did remote debugging on my local system and after 2 steps the debugger froze. Not the UI but it did not moved to
another line. Only Stop, Continue, Step over expression, Run to cursor and Apply changes get enabled again but it is
impossible to continue in debugging.

I can reliably reproduce it with following steps:
1. In remote IDE do Refactoring/Move class to another package
2. remotely connect debugger through socket
3. put a break point into refactoring.api/org.netbeans.modules.refactoring.spi.impl.UndoManager.SessionUndoItem.undo()
at line 597
4. do Refactoring/Undo in the remote IDE
5. step into
6. step over
7. and that is it.

I have open Watches and Variables tabs besides others.
Comment 1 Jan Pokorsky 2009-10-20 11:52:19 UTC
Created attachment 89753 [details]
thread dump
Comment 2 Jan Pokorsky 2009-10-20 11:52:56 UTC
Created attachment 89754 [details]
another thread dump
Comment 3 Vojtech Sigler 2009-10-20 14:23:44 UTC
From the looks of it seems like a duplicate of http://www.netbeans.org/issues/show_bug.cgi?id=174849

I unable to reproduce using the following configuration:
Product Version: NetBeans IDE Dev (Build 20091020112920)
Java: 1.6.0_16; Java HotSpot(TM) 64-Bit Server VM 14.2-b01
System: Linux version 2.6.31-14-generic running on amd64; UTF-8; en_US (nb)

The build is today's first successful (trunk) from deadlock and contains fix to the abovementioned issue. Could you
please try with the latest build from deadlock or rebuild your version?
Comment 4 Jan Pokorsky 2009-10-20 15:07:59 UTC
Yes, main#18279e58b2a2 seems to help. Thanks for pointer.

*** This issue has been marked as a duplicate of 174849 ***
Comment 5 Marian Mirilovic 2010-05-06 08:02:40 UTC
verified duplicate


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo