Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 174869 - Debugging two top level classes in one file - debugger lockup
Debugging two top level classes in one file - debugger lockup
Status: CLOSED DUPLICATE of bug 174849
Product: debugger
Classification: Unclassified
Component: Java
6.x
All Windows Vista
: P1 (vote)
: 6.x
Assigned To: issues@debugger
issues@debugger
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-19 12:31 UTC by Vojtech Sigler
Modified: 2010-05-06 08:02 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vojtech Sigler 2009-10-19 12:31:15 UTC
Product Version: NetBeans IDE Dev (Build 200910170201)
Java: 1.6.0_16; Java HotSpot(TM) Client VM 14.2-b01
System: Windows Vista version 6.0 running on x86; Cp1252; en_US (nb)

1) Open MemoryView project (http://qa.netbeans.org/modules/debugger/promo-h/MemoryView.zip)
2) Open ClazzOne.java
3) Put line breakpoint on line 27
4) Debug file
5) When debugger stops step into method doit()
6) Invoke Continue
7) Now all debugging actions (pause,  continue, step over, step over expression, step into, step out) are disabled and
the application is still stopped at line 39

No messages in messages.log.
Comment 1 Martin Entlicher 2009-10-19 14:07:55 UTC
Maybe this is already reported in issue #174849 - I'll check this after that issue is fixed.
Comment 2 Vojtech Sigler 2009-10-19 14:23:50 UTC
I found that issue before and it looks similar, but I cannot tell if it is the same. Reported just to be sure. :)
Comment 3 Vojtech Sigler 2009-10-19 14:37:36 UTC
Since it is not yet confirmed that this is a duplicate of #174849, I consider this a stopper for beta.
Comment 4 Martin Entlicher 2009-10-20 08:25:06 UTC
After the fix of issue #174849 this works fine, therefore this is a duplicate of it.

*** This issue has been marked as a duplicate of 174849 ***
Comment 5 Marian Mirilovic 2010-05-06 08:02:40 UTC
verified duplicate


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo