Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 172345 - Rename refactoring leads to compilation error when applied on a method in a complex class hierarchy
Rename refactoring leads to compilation error when applied on a method in a c...
Status: RESOLVED DUPLICATE of bug 111953
Product: java
Classification: Unclassified
Component: Refactoring
6.x
PC Linux
: P2 (vote)
: TBD
Assigned To: issues@java
issues@java
:
: 172344 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-16 03:04 UTC by vilasshekharbj
Modified: 2009-09-16 11:16 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vilasshekharbj 2009-09-16 03:04:47 UTC
Apply the rename refactoring on B.m() in the following code and rename it to 'p':

interface B {
  public void m();
}
interface A {
  public void m();
}
class C implements A, B {
  public void m(){}
}

The refactoring fails to detect that it should also rename A.m() and leads to the following code that does not compile:

interface B {
  public void p();
}
interface A {
  public void m();
}
class C implements A, B {
  public void p(){}
}
Comment 1 vilasshekharbj 2009-09-16 03:05:10 UTC
*** Issue 172344 has been marked as a duplicate of this issue. ***
Comment 2 Jiri Prox 2009-09-16 11:16:40 UTC
This is already filed, but IMHO it is not so frequent test case

*** This issue has been marked as a duplicate of 111953 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo