Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 111953 - [rename method] Ren. Method does not renamed correctly
[rename method] Ren. Method does not renamed correctly
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Refactoring
6.x
PC Windows XP
: P4 (vote)
: 7.1
Assigned To: Ralph Ruijs
issues@java
:
: 103445 172345 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-03 20:35 UTC by kely_garcia
Modified: 2011-08-04 13:50 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kely_garcia 2007-08-03 20:35:07 UTC
Build ID: Netbeans 6.0 M9 (070502)

Steps To Reproduce:
Rename method I.m to k in the following:
class B {
 public void m(){};
}
class A extends B implements I{
 public void m(){};
}
interface I {
 void m();
}

Yields the following refactored code:
class B {
    public void m(){};
}
class A extends B implements I{
    public void k(){};
}
interface I {
    void k();
}

Note: Method B.m() was not renamed.
Comment 1 kely_garcia 2007-08-03 20:43:33 UTC
In this other example, renaming method I.m to k on the following yields compilation error: "A is not abstract and does 
not override abstract method I.m()"
class B {
	public void m(){};
} 
class A extends B implements I{
} 
interface I {
	void m();
}
Comment 2 Jan Becicka 2007-08-07 12:08:19 UTC
Valid test case, but P4 imo.
Comment 3 Jiri Prox 2009-09-16 11:16:40 UTC
*** Issue 172345 has been marked as a duplicate of this issue. ***
Comment 4 Jan Becicka 2011-01-07 08:07:05 UTC
*** Bug 103445 has been marked as a duplicate of this bug. ***
Comment 5 Jan Becicka 2011-07-25 14:04:42 UTC
pls, evaluate. Thanks
Comment 6 Ralph Ruijs 2011-08-01 14:22:13 UTC
Changeset: bae49fa518f1
Author:    Ralph Benjamin Ruijs <ralphbenjamin@netbeans.org>
Date:      2011-08-01 16:11
Message:   
Issue #111953 - [rename method] Ren. Method does not renamed correctly
Comment 7 Quality Engineering 2011-08-04 13:50:09 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/bae49fa518f1
User: Ralph Benjamin Ruijs <ralphbenjamin@netbeans.org>
Log: Issue #111953 - [rename method] Ren. Method does not renamed correctly


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo