Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 172344 - Rename refactoring leads to compilation error when applied on complex class hierarchy
Rename refactoring leads to compilation error when applied on complex class h...
Status: RESOLVED DUPLICATE of bug 172345
Product: java
Classification: Unclassified
Component: Refactoring
6.x
PC Linux
: P2 (vote)
: TBD
Assigned To: issues@java
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-16 02:49 UTC by vilasshekharbj
Modified: 2009-09-16 03:05 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vilasshekharbj 2009-09-16 02:49:56 UTC
Apply the rename refactoring on B.m() in the following code and rename it to 'p':

interface B {
  public B m();
}
interface C {
  public C m();
}
class A implements C, B {
  public A m(){
    A a=null;
    return a;
  }
}

The refactoring fails to detect that it should also rename C.m() and leads to the following code that does not compile:

interface B {
  public B p();
}
interface C {
  public C m();
}
class A implements C, B {
  public A p(){
    A a=null;
    return a;
  }
}
Comment 1 vilasshekharbj 2009-09-16 03:05:10 UTC

*** This issue has been marked as a duplicate of 172345 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo