Bug 169359 - AWT thread blocked for 38727 ms.
AWT thread blocked for 38727 ms.
Status: VERIFIED FIXED
Product: projects
Classification: Unclassified
Component: Maven
6.x
All All
: P2 (vote)
: 6.x
Assigned To: David Simonek
issues@platform
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
: 171796 172970 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-28 16:32 UTC by Ivan Sidorkin
Modified: 2010-09-23 13:14 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (64.76 KB, bin/nps)
2009-07-28 16:32 UTC, Ivan Sidorkin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Sidorkin 2009-07-28 16:32:32 UTC
Build: NetBeans IDE Dev (Build 200907280201)
VM: Java HotSpot(TM) 64-Bit Server VM, 11.3-b02-83, Java(TM) SE Runtime Environment, 1.6.0_13-b03-211
OS: Mac OS X, 10.5.7, x86_64

User Comments:
ivansidorkin: opening/working with hudson project properties


Maximum slowness yet reported was 38727 ms, average is 38727
Comment 1 Ivan Sidorkin 2009-07-28 16:32:37 UTC
Created attachment 85361 [details]
nps snapshot
Comment 2 David Simonek 2009-09-14 16:56:58 UTC
I'm taking this one...
Comment 3 David Simonek 2009-09-15 14:46:18 UTC
fixed, loading of profiles re planned outside EQ thread:
e8f0b3e5ea31
Comment 4 Quality Engineering 2009-09-18 22:18:25 UTC
Integrated into 'main-golden', will be available in build *200909181401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/e8f0b3e5ea31
User: Dafe Simonek <dsimonek@netbeans.org>
Log: #169359: loading of profiles for profile completion replanned out of EQ thread
Comment 5 David Simonek 2009-09-22 12:52:14 UTC
*** Issue 171796 has been marked as a duplicate of this issue. ***
Comment 6 Jaroslav Pospisil 2009-11-18 08:55:56 UTC
v.
Comment 7 Antonin Nebuzelsky 2010-09-23 13:14:35 UTC
*** Bug 172970 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo