Bug 172970 - [68cat] AWT thread blocked for 18323 ms.
[68cat] AWT thread blocked for 18323 ms.
Status: RESOLVED DUPLICATE of bug 169359
Product: projects
Classification: Unclassified
Component: Maven
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Antonin Nebuzelsky
issues@platform
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-24 09:06 UTC by Exceptions Reporter
Modified: 2010-09-23 13:14 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (34.67 KB, bin/nps)
2009-09-24 09:06 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2009-09-24 09:06:32 UTC
Build: NetBeans IDE Dev (Build 200908022240)
VM: Java HotSpot(TM) 64-Bit Server VM, 14.0-b16, Java(TM) SE Runtime Environment, 1.6.0_14-b08
OS: Linux, 2.6.28-15-generic, amd64

User Comments:
neilg: clicked on actions in maven project properties dialog

neilg: Looking at maven project properties - build and actions.

GUEST: I have a Maven project, which wraps 2 maven projects, which eachs wraps 9 and 5 projects. I opened the parent project properties and went to Actions page.

GUEST: I was opening the property windows of a maven projet.


Maximum slowness yet reported was 18323 ms, average is 6480
Comment 1 Exceptions Reporter 2009-09-24 09:06:37 UTC
Created attachment 88252 [details]
nps snapshot
Comment 2 Exceptions Reporter 2009-09-24 09:06:42 UTC
This issue already has 6 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=158041
Comment 3 Antonin Nebuzelsky 2010-07-30 15:17:33 UTC
Reassigning to default owner.
Comment 4 Antonin Nebuzelsky 2010-09-23 13:14:35 UTC
The time is spent loading profiles (and initializing embedder) in org.netbeans.modules.maven.customizer.ActionMappings.addNotify().

Already fixed in issue 169359 by Dafe. No more reports here since then.

*** This bug has been marked as a duplicate of bug 169359 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo