Bug 158735 - StackOverflowError at org.netbeans.modules.ide.ergonomics.newproject.FeatureOnDemanWizardIterator.hasNext
StackOverflowError at org.netbeans.modules.ide.ergonomics.newproject.FeatureO...
Status: RESOLVED FIXED
Product: ide
Classification: Unclassified
Component: Features On Demand
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Pavel Flaska
issues@performance
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
: ERGONOMICS, RANDOM
: 159379 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-18 13:23 UTC by Jiri Prox
Modified: 2009-06-21 13:43 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (134.03 KB, text/plain)
2009-02-18 13:23 UTC, Jiri Prox
Details
stacktrace (134.03 KB, text/plain)
2009-02-18 18:30 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Prox 2009-02-18 13:23:37 UTC
Build: NetBeans IDE Dev (Build 200902172055)
VM: Java HotSpot(TM) Client VM, 11.2-b01, Java(TM) SE Runtime Environment, 1.6.0_12-b04
OS: Linux, 2.6.24-23-generic, i386

User Comments:
jiriprox: SOE when creating new project. IDE was started on JRE, not JDK

alexvsimon: try to create C/C++ project

msandor: Creating a new java application a clicking on the Activate button

jiriprox: SOE when creating new project. IDE was started on JRE, not JDK



Stacktrace: 
java.lang.StackOverflowError
        at org.netbeans.modules.ide.ergonomics.newproject.FeatureOnDemanWizardIterator.hasNext(FeatureOnDemanWizardIterator.java:230)
        at org.netbeans.modules.ide.ergonomics.newproject.FeatureOnDemanWizardIterator.hasNext(FeatureOnDemanWizardIterator.java:231)
        at org.netbeans.modules.ide.ergonomics.newproject.FeatureOnDemanWizardIterator.hasNext(FeatureOnDemanWizardIterator.java:231)
        at org.netbeans.modules.ide.ergonomics.newproject.FeatureOnDemanWizardIterator.hasNext(FeatureOnDemanWizardIterator.java:231)
        at org.netbeans.modules.ide.ergonomics.newproject.FeatureOnDemanWizardIterator.hasNext(FeatureOnDemanWizardIterator.java:231)
        at org.netbeans.modules.ide.ergonomics.newproject.FeatureOnDemanWizardIterator.hasNext(FeatureOnDemanWizardIterator.java:231)
Comment 1 Jiri Prox 2009-02-18 13:23:48 UTC
Created attachment 77098 [details]
stacktrace
Comment 2 Exceptions Reporter 2009-02-18 18:30:28 UTC
Build: NetBeans IDE Dev (Build 200901080201)
VM: Java HotSpot(TM) 64-Bit Server VM, 11.0-b15, Java(TM) SE Runtime Environment, 1.6.0_10-b33
OS: Linux, 2.6.27-11-generic, amd64

User Comments: 
I was just creating a new Web Application Project and the dialog asked me to activate de SaaS service

Stacktrace: 
java.lang.StackOverflowError
        at org.netbeans.modules.ide.ergonomics.newproject.FeatureOnDemanWizardIterator.hasNext(FeatureOnDemanWizardIterator.java:231)
        at org.netbeans.modules.ide.ergonomics.newproject.FeatureOnDemanWizardIterator.hasNext(FeatureOnDemanWizardIterator.java:231)
        at org.netbeans.modules.ide.ergonomics.newproject.FeatureOnDemanWizardIterator.hasNext(FeatureOnDemanWizardIterator.java:231)
        at org.netbeans.modules.ide.ergonomics.newproject.FeatureOnDemanWizardIterator.hasNext(FeatureOnDemanWizardIterator.java:231)
        at org.netbeans.modules.ide.ergonomics.newproject.FeatureOnDemanWizardIterator.hasNext(FeatureOnDemanWizardIterator.java:231)
        at org.netbeans.modules.ide.ergonomics.newproject.FeatureOnDemanWizardIterator.hasNext(FeatureOnDemanWizardIterator.java:231)
Comment 3 Exceptions Reporter 2009-02-18 18:30:39 UTC
Created attachment 77120 [details]
stacktrace
Comment 4 Exceptions Reporter 2009-03-03 21:22:14 UTC
This issue has already 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=145412
Comment 5 Pavel Flaska 2009-03-04 07:29:04 UTC
The same as #156273, which has been considered fixed, but still does not work...

Comment 6 Quality Engineering 2009-03-09 21:07:48 UTC
Integrated into 'main-golden', will be available in build *200903091401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/a8293c0343ce
User: Pavel Flaska <pflaska@netbeans.org>
Log: #158735: StackOverflow - caused by another exception. Right now, the StackOverflow shouldn't be reproducible.
Comment 7 Pavel Flaska 2009-03-12 16:09:26 UTC
Fixed.
Comment 8 Pavel Flaska 2009-03-13 09:58:30 UTC
*** Issue 159379 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo