Bug 141198 - Merge Conflicts Resolver should have ability to use changes from both version
Merge Conflicts Resolver should have ability to use changes from both version
Status: RESOLVED FIXED
Product: utilities
Classification: Unclassified
Component: Diff
7.3
All All
: P3 with 19 votes (vote)
: 8.0
Assigned To: Ondrej Vrabec
diff-issues@utilities
:
: 208431 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-22 16:56 UTC by sjh
Modified: 2013-09-03 15:09 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sjh 2008-07-22 16:56:08 UTC
The Merge conflicts resolver, allows one to choose the changes in one file or the other.  There are many times that
changes have been made on the same line in each file, but are unrelated and thus we need both changes.  Just as a
suggestion, the Cervesia conflict resolver (part of KDevelop), does this by adding two options of "A+B" and "B+A".

It would also be nice to be able to directly edit the merged result in the resolver too.
Comment 1 Peter Pis 2008-10-23 12:41:43 UTC
Reassigning to diff. It's a general issue for all VCSs supported by the IDE.
Comment 2 markiewb 2013-05-01 19:58:51 UTC
*** Bug 208431 has been marked as a duplicate of this bug. ***
Comment 3 Ondrej Vrabec 2013-09-03 15:09:47 UTC
fix: http://hg.netbeans.org/core-main/rev/e7538c187920


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo