Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 208431 - Adding Merge Action(Accept Both) for Merge Conflicts Resolver Editor.
Adding Merge Action(Accept Both) for Merge Conflicts Resolver Editor.
Status: RESOLVED DUPLICATE of bug 141198
Product: utilities
Classification: Unclassified
Component: Diff
7.1
PC Windows 7
: P3 with 8 votes (vote)
: TBD
Assigned To: Tomas Stupka
diff-issues@utilities
:
: 228660 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-15 03:07 UTC by fortruth
Modified: 2013-05-01 19:58 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fortruth 2012-02-15 03:07:21 UTC
Product Version = NetBeans IDE 7.1 (Build 201112071828)
Operating System = Windows 7 version 6.1 running on amd64
Java; VM; Vendor = 1.6.0_24
Runtime = Java HotSpot(TM) 64-Bit Server VM 19.1-b02


I have an suggestion about the Merge Conflicts Resolver Editor.

That here could have an button for action, merge the conflict lines not only the accept.

I think many people need this action. to keep the conflict line all accepted, not just one side.(local or remote)..

For Example:
==========================
Remote file

74     this is remote added string here..
==========================
Local Working File

74     this is local added string here...


==========================
then the expected result for merge action will be

74     this is remote added string here..
75     this is local added string here...
Comment 1 Ondrej Vrabec 2013-04-17 13:28:15 UTC
*** Bug 228660 has been marked as a duplicate of this bug. ***
Comment 2 markiewb 2013-05-01 19:58:51 UTC
IMHO duplicate of 141198. 

@Original voters of 208431: Please vote again at https://netbeans.org/bugzilla/show_bug.cgi?id=141198

*** This bug has been marked as a duplicate of bug 141198 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo