Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 136936 - JavaScript refactoring bugs
JavaScript refactoring bugs
Status: VERIFIED FIXED
Product: javascript
Classification: Unclassified
Component: Editor
6.x
Macintosh All
: P2 (vote)
: 6.x
Assigned To: Torbjorn Norbye
issues@javascript
61fixes2-fixed
:
: 135290 135392 135477 136055 136111 136616 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-10 17:35 UTC by Torbjorn Norbye
Modified: 2009-02-27 14:26 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Torbjorn Norbye 2008-06-10 17:35:28 UTC
There were a handful of bugs related to JavaScript refactoring that I fixed in changeset b5a5bdef0148:
http://hg.netbeans.org/main/rev/b5a5bdef0148

Fix a series of bugs around JavaScript refactoring. Several of these are dupes, but there are 3-4 distinct issues here.
135290: NullPointerException at org.netbeans.modules.refactoring.javascript.RetoucheUtils.getClasspathInfoFor
136830: AssertionError when refactoring .js
136055: Find usages throws an error message.
135392: NPE when renaming JavaScript outside of the editor
135477: Module JavaScript Refactoring threw java.lang.NullPointerException
136616: NullPointerException at java.lang.String.indexOf
136111: NullPointerException at java.lang.String.indexOf

All together this represents a changeset I believe we should release in a patch. The code fixes are pretty simple; some
null pointer checks, some code to ensure that refactoring is only run in project types that support refactoring, and
some code to ensure that the refactoring name is valid.  

There are a number of duplicates for the above issues reported via the exceptions feedback tool. Therefore, I think it's
important that we port this to the fixes branch, and rather than nominating each and every issue I thought a meta issue
covering them all was clearer.
Comment 1 Torbjorn Norbye 2008-06-10 17:37:34 UTC
Fixed in 6.5, should fix in 6.1 so marking with the 61fixes2-candidate status whiteboard key.
Comment 2 Torbjorn Norbye 2008-06-10 17:38:50 UTC
*** Issue 135477 has been marked as a duplicate of this issue. ***
Comment 3 Torbjorn Norbye 2008-06-10 17:39:51 UTC
*** Issue 135290 has been marked as a duplicate of this issue. ***
Comment 4 Torbjorn Norbye 2008-06-10 17:40:32 UTC
*** Issue 135392 has been marked as a duplicate of this issue. ***
Comment 5 Torbjorn Norbye 2008-06-10 17:40:43 UTC
*** Issue 136055 has been marked as a duplicate of this issue. ***
Comment 6 Torbjorn Norbye 2008-06-10 17:41:05 UTC
*** Issue 136111 has been marked as a duplicate of this issue. ***
Comment 7 Torbjorn Norbye 2008-06-10 17:41:19 UTC
*** Issue 136616 has been marked as a duplicate of this issue. ***
Comment 8 Torbjorn Norbye 2008-06-10 17:41:46 UTC
*** Issue 136830 has been marked as a duplicate of this issue. ***
Comment 9 jinb 2008-06-11 15:43:49 UTC
QA, please verify this fix till 12-Jun-2008, so it can be part of NB 6.1 patch 2.
Comment 10 Torbjorn Norbye 2008-06-11 17:12:25 UTC
There was a typo in the original patch, thanks to Martin Schovanek for catching it. I've added additional changeset
279b04701656
which should be included in the release branch as well.
Comment 11 Martin Schovanek 2008-06-12 15:09:48 UTC
v.
Comment 12 jinb 2008-06-12 18:23:32 UTC
fix backported into release61_fixes branch
http://hg.netbeans.org/release61_fixes/rev/411a5491d2af
Comment 13 polan 2008-06-18 12:35:49 UTC
Issue 136830 is not fixed by this fix. See the issue for details.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo